Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a windows 7 machine w/ nvidia NVS4200 chipiset 'fragmentation' (I don't know exactly what you would call it) occurs when playing certain video files with VLC, when a certain setting in VLC is turned on. The following illustrates the issue:

Here are two comparison screenshots to illustrate what happens when "Use GPU accel..." is turned on. The first is w/ it on, the second is with it off (all preferences were reset to default before taking each screenshot), and the third is from the nvidia 3d setting menu: enter image description here

enter image description here

enter image description here

share|improve this question
    
have you updated your nvidia drivers recently? are your 3D settings overriding application preferences or defering to them? –  Frank Thomas Feb 16 '13 at 23:10
    
yes, they're up to date. And see the original question to see if the 3d settings are what you are talking about. –  jhstuckey Feb 16 '13 at 23:17
add comment

2 Answers 2

up vote 1 down vote accepted

I've found out that on laptops with 2 graphics processors (integrated and dedicated) simply ticking the hardware accelerated graphics box in VLC is insufficient as NVIDIA will still insist on using integrated graphics due to its preset profile, which explains why you can't access the drop down menu to change the GPU. one way around this is to rename the vlc.exe into something else (i.e. vlc-gpu.exe) and then add that program in the NVIDIA control panel. the other drawback to enabling GPU acceleration is that when laptops are on any power mode other than high performance, the GPU is usually disabled. which results in the pixelation as you laptop then resorts to integrated graphics.

I'm not a professional but this is what I found out from looking up online and this is also what eventually worked for me.

share|improve this answer
add comment

I suspect that the videos you are playing are either 1080p (full HD) or 1080p High Profile and your graphics card simply lacks the video decoding power to use hardware decoding with these videos. VLC is simply too dumb to notice this fact and tells the graphics card to do it anyway.

The NVS4200, having only 48 cores, is relatively underpowered for any modern job requiring any real amount of processing power. From what I can find the 4200 is essentially a rebadged GT520M though from what I can see the 520M should be able to do pretty much any given 1080p stream without problems, even to the point of decoding multiple 1080 streams concurrently.

Have you tried another player like MPC-HC which I've always found to be very passable.

What is the other option besides "integrated grapics" in the dropdown you show? It may be that your "integrated" graphics is a mediocre graphics device that struggles with 1080 video.

share|improve this answer
    
Thanks for the reply. I haven't tried other players. The drop down box is grayed out; you can only select integrated. –  jhstuckey Feb 16 '13 at 23:32
    
Do you have an example of a video that fails to play? Preferably some kind of freely available trailer or something. –  Mokubai Feb 16 '13 at 23:48
    
works fine with mpc-hc –  jhstuckey Feb 17 '13 at 21:24
    
Oh, and the video is a 720p not 1080p mkv file. –  jhstuckey Feb 17 '13 at 21:34
    
If you want to be sure that it is using the graphics card to decode the video then you'll want to make sure it says "Playing [DXVA]" as in this screenshot, otherwise it is falling back to software decoding for some reason. Other than that this could be a VLC bug, I've never been particularly impressed with VLC, it seems to be a "jack of all trades" software in that it has a multitude of codecs and can play almost all videos but it doesn't particularly excel in any way at all. –  Mokubai Feb 17 '13 at 22:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.