Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 16 GB SD card i'm trying to format for use. In Windows if I try to format it says Windows was unable to complete the format, and in Linux when I do fdisk -l -u, fdisk just hangs when the SD card is in. GParted also hangs if I try to open it up.

There are also some files on it, if I delete these files, unplug the SD card and plug it back in, the files reappear.

I tried using SDFormatter from www.sdcard.org, which says it's write-protected. But I have already tried flipping the switch on the SD card, which didn't change anything.

How can I format this thing?

share|improve this question
    
Might be a silly suggestion, but does your SD card have a physical read-only switch on the outside? – Ben Mordecai Feb 17 '13 at 4:07
    
@BenMordecai it does. I've tried switching it back and forth, neither work. – Josh Feb 17 '13 at 13:35
up vote 2 down vote accepted

If this is actually a Micro/Mini SD card in an SD card adapter, try to get a different adapter. I had 3 Kingston adapters that failed exactly like that - they became read-only.

Also try to do these operations in another computer/card reader. It is possible you have issues with your reader.

If these things don't help, I think this card is somehow defective and it's time to trash it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .