Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I enabled the Telnet Server feature in Windows 7 SP1, and after 20 reboots later and some pinging find it is simply not working. I cannot ping port 23.. but Windows Firewall says the Incoming connection for "Telnet" is open.. does anyone know any why to get this working? Thanks :)

share|improve this question
3  
Are you trying to telnet across your LAN or across the internet? And what is this about pinging port 23? What does it mean that you're pinging the telnet TCP port? –  Nicole Hamilton Feb 17 '13 at 5:46
    
Check if Telnet service is running on "server" PC. Check your "server" PC event log for errors. –  Maximus Feb 17 '13 at 8:09
    
@NicoleHamilton, its a LAN network of 3 computers all behind a home wireless router. I have tried going into terminal/command line ON the computer and on other computers pinging "localhost:23" and (the network IP) 192.168.0.3:23, it does not ping, the port is closed when the service is turned on? –  seanthewebber Feb 17 '13 at 16:36
    
@Maximus, Under the "Windows Features" page "Telnet Client" and "Telnet Server" are both running. Under the firewall it says Incoming connections for "Telnet Server" are open to All (Private/Public networks). I will do that, uno momento. –  seanthewebber Feb 17 '13 at 16:39
    
I could be wrong, but I don't think you can ping anything:23 and ever expect it to do anything useful under Windows. If you'd like to ping a machine, you need to make sure your firewall (probably in whatever antivirus software you're using) will pass those UDP packets. –  Nicole Hamilton Feb 17 '13 at 17:03
show 2 more comments

1 Answer

up vote 2 down vote accepted

For the sake of troubleshooting, it might not hurt to temporarily turn off the Windows firewall, then Avast (or any other antivirus.) Might not hurt to do this on both sides of the connection either.

Also keep in mind that you can't ping a port. Use telnet 192.168.0.3 to connect to the telnet service. If that doesn't work, then telnet isn't working.

Check to make sure the telnet service is running under Control Panel, Administrative Tools, Services.

share|improve this answer
    
Oh my gosh.. I am an idiot. Even though I enabled it in Windows Features, it was Disbaled in Services.. I turned it to Automatic and it started up immediately… Thanks!!! –  seanthewebber Feb 17 '13 at 19:09
1  
But be aware that telnet is not secure so you should be careful using it. A better alternative is a a secure shell, like PuTTY. –  Nicole Hamilton Feb 17 '13 at 20:27
    
Yes, thanks for the info. The reason I use telnet is its simple, its only on my local home network, and I don't have to deal with annoying RSA keys every time a computer changes IP addresses on the DHCP. –  seanthewebber Feb 17 '13 at 20:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.