Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to turn off Address Space Layout Randomization (ASLR) in Ubuntu 12.04.

What I have done is set randomized_va_space to 0 but still when I am looking at /proc/<process_id>/maps for my memory what I am getting is a randomized allocation of segments, even when I run the same program many times.

How to completely turn off ASLR in Ubuntu 12.04?

share|improve this question
add comment

1 Answer

I'm sorry but I'm not sure of the problem. I can try to help you troubleshoot though.

  1. Are you certain that the setting took properly? Sometimes using sudo echo "0" > /proc/sys/kernel/randomize_va_space can fail due to lack of permissions, because the sudoness is dropped when running the >.
  2. Have you rebooted since applying the setting?
  3. Is there a particular reason that your are disabling ASLR? I'm sure you know that can open up quite a security vulnerability. If you are doing exploit development or security research, you may want to switch to an older version of Ubuntu/Linux, or to a specialized distro like DVL (if you can find a copy).
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.