Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My KDE4 give me this error message when I try to configure my WIFI.

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

The message is so general, I have no idea what it means...:(

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Many KDE programs use a message bus called D-Bus to communicate with each other, and with various system services.

(Your system has two dbus-daemon instances running, one managing the "session" bus (which is specific to your current KDE session, and has no restrictions), the other managing the "system" bus (which is used by system services and is highly restricted).)

The usual causes for this error message are:

  • KDE tried to send a message to another program, but the program was hung and didn't reply fast enough.
  • KDE tried to send a message to a system service, but either the message itself, or the reply, were blocked by the system bus security restrictions.

You should check your system log to see if there are any error messages from dbus-daemon, or from NetworkManager (which KDE uses to configure WiFi connections). In fact, make sure Network­Manager is even installed and running.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.