Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I finally decided to make a thread after fighting with this problem for very long.

First, let's see what i have in the registry: Registry editor

Second, I have these pending updates: Updates

What i try to do now, is: update my computer :o

The problem is that when i restart my computer to finish the installation, i will reach the point saying 98% completed (or something similar), then it completes i think, but it says: reverting updates.

When i boot up again, i went to the event log, to find these errors: Windows error log viewer

.net Framework 3.5 is enabled in windows features. I suspect it might have something to do with my boot, i have a different boot record than windows'

share|improve this question
    
Can you install all the other updates besides KB2795944? Have you tried installing it manually? – Ƭᴇcʜιᴇ007 Feb 17 '13 at 16:12
    
they all return the same error – Abdullah Gheith Feb 17 '13 at 18:19
1  
zip and upload the folder C:\Windows\logs\CBS (copy the folder first to the desktop) and post a link here. – magicandre1981 Feb 17 '13 at 19:47
    
So what i did: deleted the content of CBS, tried to update again, got the error again and uploaded the logs (so that you would have a fresh log without too much irrelevant stuff): ayg.dk/CBS.zip – Abdullah Gheith Feb 17 '13 at 22:05
up vote 1 down vote accepted

Updating the EFI Boot components fails for your:

2013-02-17 22:53:09, Info                  CSI    000000aa Begin executing advanced installer phase 38 (0x00000026) index 78 (0x000000000000004e) (sequence 117)
    Old component: [ml:358{179},l:356{178}]"Microsoft-Windows-BootEnvironment-Core-BootManager-EFI, Culture=neutral, Version=6.2.9200.16420, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=amd64, versionScope=NonSxS"
    New component: [ml:358{179},l:356{178}]"Microsoft-Windows-BootEnvironment-Core-BootManager-EFI, Culture=neutral, Version=6.2.9200.16384, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=amd64, versionScope=NonSxS"
    Install mode: install
    Installer ID: {c5f0e9d7-e844-4507-89e4-701b5a747221}
    Installer name: [34]"CSI Boot File Servicing (BFSVC) AI"
2013-02-17 22:53:09, Error                 CSI    000000ab@2013/2/17:21:53:09.374 (F) base\wcp\plugins\bfsvc\bfsvc.cpp(218): Error HRESULT_FROM_WIN32(123) originated in function Windows::WCP::Bfsvc::BasicInstaller::Install expression: HRESULT_FROM_WIN32(GetLastError())
[gle=0x80004005]

Use boot recovery option to repair the BCD store. Also make sure the 350MB partition which contains the bootloader is not full.

share|improve this answer
    
Thank you, that seemed to solve some of the problem i guess. But windows update is still not working properly, The only missing update is now this one: KB2770816 ayg.dk/CBS.log – Abdullah Gheith Feb 22 '13 at 2:30
    
To answer myself, according to this site: bit.ly/ZvFlWM the cause of that error is an entry in the registry db. I tried creating it myself but i couldn't, regedit said it already existed even though it didn't. I downloaded a software called: Registrar Registry Manager. Then created the entry, and it updated like a charm! Again, thank you magicandre, you certainly are magic :p I looked in the log myself but didn't see that. – Abdullah Gheith Feb 22 '13 at 2:44
    
nice to hear that the issue is fixed :) – magicandre1981 Feb 22 '13 at 4:51

I have had the same issue.

After uninstallation of IObit Start menu 8 the Windows Update are working.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Dave M Apr 11 '14 at 13:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .