Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to remove as much processes as possible to minimize the boot time on a beaglebone running ubuntu minimal. So i want to remove udev-fallback-graphics and all plymouth processes. I tried 'sysv-rc-conf' and 'rcconf' and 'update-rc.d -f' and nothing worked. By removing those processes i can gain about 4-5 seconds which is very important for the project i have. The dmesg gave me this:

[    7.855712] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   10.704010] init: udev-fallback-graphics main process (443) terminated with status 1
[   10.853881] PHY: 0:00 - Link is Up - 100/Full
[   10.854125] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   11.418457] init: plymouth main process (174) killed by ABRT signal
[   11.446380] init: plymouth-splash main process (470) terminated with status 2
[   13.843292] init: plymouth-stop pre-start process (686) terminated with status 1
share|improve this question
upstart is supposed to paralellize bootup as much as possible, so deleting something that takes 5 seconds won't win you 5 seconds. – vonbrand Feb 17 '13 at 19:11
I disabled ipv6 and it saved me 20 seconds of boot time.The goal is to reach the boot time to about 5 to 6 seconds which is required by my project.Even if it's not 5 seconds Its good enough since its nearer to the goal – vkefallinos Feb 18 '13 at 1:04

upstart services aren't affected by any sysvinit config tool. Apparently, to disable SERVICE, you need to create a file /etc/init/SERVICE.override containing the word "manual".

share|improve this answer
I have tried the sudo sh -c "echo 'manual' > /etc/init/SERVICE.override" command but cant figure out if it was any good because i must have stopped services necessary for network.So i cant tell if this is the answer.Tomorrow with further tests... – vkefallinos Feb 18 '13 at 1:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.