Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a desktop running Ubuntu Server 12.04 with samba installed to share files to multiple Windows computers in the house.

I have a folder /test which has it's permissions set like so:

drwxrwsrwx 2 alex nodel 4096 Feb 17 15:39 /test

I have set GID so all files and folders created in this folder will have the group nodel (alex is my admin account and is the only member of the nodel group, I also have standard user izzie)

Here is my samba smb.conf:

     workgroup = WORKGROUP
     server string = %h server (Samba, Ubuntu)
     netbios name = Acacia
     dns proxy = no
     log file = /var/log/samba/log.%m
     max log size = 1000
     syslog = 0
     socket options = TCP_NODELAY
     panic action = /usr/share/samba/panic-action %d
     security = user
     encrypt passwords = true
     passdb backend = tdbsam
     large readwrite = yes
     dos charset = CP850
     unix charset = UTF8
     display charset = LOCALE
     obey pam restrictions = yes
     unix password sync = yes
     passwd program = /usr/bin/passwd %u
     pam password change = yes
     guest account = nobody
     map to guest = bad user
     wins support = yes
     usershare max shares = 100
     usershare allow guests = yes

     comment = test
     path = /test
     nt acl support = yes
     browseable = yes
     writeable = yes
     create mask = 0570
     force create mode = 0570
     directory mask = 0570
     force directory mode = 0570

The share forces all new files and folders to be created with group write only (shown below)

dr-xrws--- 2 alex nodel 4096 Feb 17 15:39 New folder
dr-xrws--- 2 izzie nodel 4096 Feb 17 15:39 New folder (2)

When user izzie creates a new file she can't delete it, nor can she delete ones I create (this is exactly what I want). However, alex can't delete them either, even though I am part of the group nodel and group has full permissions. This is all in the Windows environment, doing this on the server enables me to delete them without sudo and logged in as alex.

If some context helps, this will be used for a video share where I want users to add there videos but not be able to delete them once they are in there, they only need read and execute as they will only be playing the videos.

Is there something I have done wrong to disable group writing in windows or is there something you have to activate to make it work?

So, my long-winded question is...How do I get group write permissions working on windows?

share|improve this question

You must log in to answer this question.

Browse other questions tagged .