Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a dedicated webserver (debian 6) running with plenty of unused capacity. While the remaining capacity isn't used i thought it'd be nice to create a virtual machine to work on using RDP.

What i tried

I've started trying VirtualBox (no specific reason), created a VM and installed Windows 7 on it. I have only 1 IP address so had to use NAT for the networking. Using the VirtualBox settings i set up some port forwarding to get RDP working.

While that worked i thought it was quite slow (screem slowly got built and only few changes where executed at once). The server has Gigabit connection (tested and works fine), i have a download speed of 120 Megabit (10 up).

I did a speedtest on the VM and the speed was awful. 2 Mbit down, 3 Mbit up. After some googling i found that it had to do with the VirtualBox network buffer sizes (http://techblog.geeksbrain.net/2012/11/how-i-solved-slow-windows-upload-speed-when-using-virtualbox-nat-or-bridged/) And also how to fix it. Increasing their size DID increase my speedtest results to 70Mbit down and 60 Mbit up but RDP barely worked at all. It got very very slow and would often lose connection.

What I want

And so I have yet to get my virtual workstation usable. Basically what I want is to get a windows VM running which is capable of using about all my unused resources (probably a little less). It cannot have a online IP address of it's own since I have only 1. It has to be accessable via RDP.

The actual question

What should i do to get the above ('What I want') running? (Doesn't have to be VirtualBox, anything that works is fine)

Thanks.

share|improve this question
    
Is your download speed really 120 megabits per second or did you mean 120 megabytes? –  gronostaj Apr 2 '13 at 16:14
    
It is megabits. I wish it was megabytes though :P –  user6 Apr 2 '13 at 17:07
    
A suggestion to help with your troubleshooting; toss wireshark on your host webserver, and keep an eye out for requests timing out. I'm not an RDP expert, but it could be that your rdp client is expecting to talk directly to the host, and trying to hit ports it thinks should be responding, that are actually being caught by the webserver. Also, I've found NAT to be notoriously unreliable. You could try a host to host network from the webserver to the windows VM and open up an ssh tunnel between them, bypassing the VBox NAT. –  Stephan Apr 3 '13 at 0:07

3 Answers 3

up vote 2 down vote accepted
+50

Some advice for similar problems :

  • Have VBox emulate an Intel PRO/1000 network card (or try other adapters)
  • Use Virtio drivers
  • In Windows, Network and Sharing Center -> Change adapter settings, disable VirtualBox Host-Only Network or any other superfluous adapter
  • In Windows, network adapter properties, disable IPv4 or IPv6 (whichever is superfluous)
share|improve this answer

I would recommend trying other hypervisors. I've had great luck with VMWare Workstation's VNC feature. Or even install VNC (or any other remote desktop service) on the VM.

share|improve this answer

Try to increase number of CPU's in your Virtual box. There is no reason why it should run so slow or lost connection "often". What is your PC specification? If you have for example Core I5, you can assign 4 CPU on 80%.. or 2 CPU on 100%. Try to play with that settings. I'm running VBox with virtual Windows and Linux server in the background on Intel i5 and all works fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.