Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

rpm (on RedHat EL 6) is giving me contradictory information:

[root@aphrodite Desktop]# rpm -e DeepFlow-1.0-1.el6.x86_64.rpm 
error: package DeepFlow-1.0-1.el6.x86_64.rpm is not installed
[root@aphrodite Desktop]# rpm -i DeepFlow-1.0-1.el6.x86_64.rpm
package DeepFlow-1.0-1.el6.x86_64 is already installed

How can my package be both installed and not installed? How can I clean up this mess?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

rpm -e expects package name as argument, not the whole rpm file. try this:

 rpm -e DeepFlow

or

 rpm -e DeepFlow-1.0

depending on whats registered as package name in the rpm db, one of them should work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.