Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For a while now, my internet connection has been seriously slow. I have changed ISP and there is still no difference. My main problem is when I play games, and it is literally unplayable. For example, Xbox Live Multiplayer games are just way to slow. I am constantly "Red Barred", whereas my friends from the same area (1-2 Same ISP) Have perfect connection.

I am on an unlimited plan with Spintel (spin.net.au - Plan: Harmony Three ) and my current router is DSL-2730B running v1.02 Firmware.

How do I go about fixing this? I am lead to believe that it is possibly my router, but being a student, I don't have the money to go and buy a $200 router.

These are the things I've already tried:

- Disconnected All Other Connected Devices
- Rebooting Router
- Updating Firmware
- Resetting Router (Factory Reset - Enter Information all over again)
- SpeedTest.net (1.5mbps, 0.4mb Upload, 255 ping (Averages))

Also, another issue I've noticed with speedtest.net is that it says I'm across the other side of the country :c

share|improve this question
    
Try a friends computer. Maybe there is a virus of something on yours. Also, you could maybe try a friends router, too (if your friends computer has slow internet too). –  BenjiWiebe Feb 18 '13 at 13:58

1 Answer 1

up vote 1 down vote accepted

I'd add this as a comment but not enough rep yet. I'm assuming this is a DSL connection based upon the model of the router. Based on that, things you might try

Remove all other devices hooked up to phone lines and test again. I've had an answering machine destroy performance. Once discovered I added a filter in line before the device and everything worked well.

Try a different wall jack. It could be as simple as faulty wiring. If that's the case you could swap to the spare pair and try again. I went so far as to disconnect all unused lines at the box as an unused line shorted out once and took all the lines down.

share|improve this answer
    
I forgot to mention that I've had multiple phones and answering machines and I have also moved house recently, and I continue to have the same problems :S –  ReallyGoodPie Feb 18 '13 at 13:47
    
So the only constant is the router and xbox. I'd be tempted to try the xbox and router separately at a friends to narrow down which component is causing the issue. –  James Thompson Feb 18 '13 at 13:58
    
After a few days of trying everything possible, I discovered that the problem was the splitter's i was trying. I had 2 at home, and they seemed to both be lagging out my connection, and i also tried one of my friends, which also did the same thing. So somehow, I ended up with another one and it works perfectly now :) –  ReallyGoodPie Feb 23 '13 at 6:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.