Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the last few days, a concern with CURL. I get this error:

curl: / lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1 'not found (required by / usr/lib/i386-linux-gnu / libcurl.so.4) 

I tried that :

php-i | grep curl :

PHP Warning: PHP Startup: Unable to load dynamic library '/ usr/lib/php5/20090626 + lfs / curl.so' - / lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1 'not found (required by / usr/lib/i386-linux-gnu/libcurl.so.4) in Unknown on line 0
/ etc/php5/cli/conf.d/curl.ini 

or :

apt-file search libssl.so.1.0.0
E: The Cache is empty. You need to run 'apt-file update' first.

and :

apt-file update : 
curl: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)
Download of http://ppa.launchpad.net/yannubuntu/os-uninstaller/ubuntu/dists/precise/Contents-i386.gz failed
Command exited with code 

So, i reinstall :

sudo apt-get install libssl-dev

sudo ln -s /usr/lib/libssl.so.1.0.0 /usr/lib/libssl.so.1.0.1

sudo apt-get remove --purge curl php5-curl libssl-dev
sudo apt-get clean
sudo apt-get autoremove --purge
sudo apt-get install --reinstall libssl1.0.0
sudo apt-get install curl php5-curl

Same problems.... :(

And some infos :

dpkg -l libcurl3 
||/ Nom                         Version                     Description
+++-===========================-===========================-================================
ii  libcurl3                    7.22.0-3ubuntu4             Multi-protocol file transfer library (OpenSSL)

ls -l /usr/lib/php5/20090626+lfs/curl.so : 
-rw-r--r-- 1 root root 71172 janv. 19 00:50 /usr/lib/php5/20090626+lfs/curl.so


cat  /etc/php5/cli/conf.d/curl.ini : 
; configuration for php CURL module
extension=curl.so

curl -V : 
curl: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)

apt-cache policy curl : 
curl:
  Installé : 7.22.0-3ubuntu4
  Candidat : 7.22.0-3ubuntu4
 Table de version :
 *** 7.22.0-3ubuntu4 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     7.21.6-3ubuntu3.2 0
         -1 http://security.ubuntu.com/ubuntu/ oneiric-security/main i386 Packages

And, of course :(, I've again the issue.

Can anybody help me ?

Thanks

share|improve this question

It seems your curl is linked against an ssl library which cannot be found on your system. If you do something like ldd /usr/lib/i386-linux-gnu/libcurl.so.4 i guess for the libssl it will tell you 'not found'?

is this one a 64 bit system or on a 32 bit system. If its on a 64 bit system, possibly /usr/lib is not even being searched for .so files. To fix this try following

echo "/usr/lib" > /etc/ld.so.conf.d/32bit_libs.conf
ldconfig

and then try running the curl command again

Otherwise you could also try this:

 sudo ln -s /usr/lib/libssl.so.1.0.0 /lib/i386-linux-gnu/libssl.so.1.0.0

Because this seems to be where ld is looking for the libraries

share|improve this answer
    
In an another forum, a guy help me. Et voilà : sudo wget security.ubuntu.com/ubuntu/pool/main/o/openssl/… et sudo dpkg -i libssl1.0.0_1.0.1-4ubuntu5.3_i386.deb – quoidautre Feb 21 '13 at 14:11

The ldd comand return this :

ldd /usr/lib/i386-linux-gnu/libcurl.so.4

/usr/lib/i386-linux-gnu/libcurl.so.4: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)

linux-gate.so.1 =>  (0xb77db000)
libidn.so.11 => /usr/lib/i386-linux-gnu/libidn.so.11 (0xb772c000)
liblber-2.4.so.2 => /usr/lib/i386-linux-gnu/liblber-2.4.so.2 (0xb771d000)
libldap_r-2.4.so.2 => /usr/lib/i386-linux-gnu/libldap_r-2.4.so.2 (0xb76ca000)
librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb76c1000)
libgssapi_krb5.so.2 => /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2 (0xb7683000)
libssl.so.1.0.0 => /lib/i386-linux-gnu/libssl.so.1.0.0 (0xb7636000)
libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xb7492000)
librtmp.so.0 => /usr/lib/i386-linux-gnu/librtmp.so.0 (0xb7477000)
libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb7461000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb72b7000)
libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xb729f000)
libsasl2.so.2 => /usr/lib/i386-linux-gnu/libsasl2.so.2 (0xb7283000)
libgssapi.so.3 => /usr/lib/i386-linux-gnu/libgssapi.so.3 (0xb7245000)
libgnutls.so.26 => /usr/lib/i386-linux-gnu/libgnutls.so.26 (0xb7181000)
libgcrypt.so.11 => /lib/i386-linux-gnu/libgcrypt.so.11 (0xb70fc000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb70e1000)
libkrb5.so.3 => /usr/lib/i386-linux-gnu/libkrb5.so.3 (0xb7012000)
libk5crypto.so.3 => /usr/lib/i386-linux-gnu/libk5crypto.so.3 (0xb6fe9000)
libcom_err.so.2 => /lib/i386-linux-gnu/libcom_err.so.2 (0xb6fe4000)
libkrb5support.so.0 => /usr/lib/i386-linux-gnu/libkrb5support.so.0 (0xb6fdb000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb6fd6000)
/lib/ld-linux.so.2 (0xb77dc000)
libheimntlm.so.0 => /usr/lib/i386-linux-gnu/libheimntlm.so.0 (0xb6fce000)
libkrb5.so.26 => /usr/lib/i386-linux-gnu/libkrb5.so.26 (0xb6f4a000)
libasn1.so.8 => /usr/lib/i386-linux-gnu/libasn1.so.8 (0xb6ea5000)
libhcrypto.so.4 => /usr/lib/i386-linux-gnu/libhcrypto.so.4 (0xb6e70000)
libroken.so.18 => /usr/lib/i386-linux-gnu/libroken.so.18 (0xb6e5a000)
libtasn1.so.3 => /usr/lib/i386-linux-gnu/libtasn1.so.3 (0xb6e48000)
libp11-kit.so.0 => /usr/lib/i386-linux-gnu/libp11-kit.so.0 (0xb6e35000)
libgpg-error.so.0 => /lib/i386-linux-gnu/libgpg-error.so.0 (0xb6e30000)
libkeyutils.so.1 => /lib/i386-linux-gnu/libkeyutils.so.1 (0xb6e2c000)
libwind.so.0 => /usr/lib/i386-linux-gnu/libwind.so.0 (0xb6e03000)
libheimbase.so.1 => /usr/lib/i386-linux-gnu/libheimbase.so.1 (0xb6df4000)
libhx509.so.5 => /usr/lib/i386-linux-gnu/libhx509.so.5 (0xb6dac000)
libsqlite3.so.0 => /usr/lib/i386-linux-gnu/libsqlite3.so.0 (0xb6d07000)
libcrypt.so.1 => /lib/i386-linux-gnu/libcrypt.so.1 (0xb6cd6000)

And I done "echo" un the conf file + ldconfig : Nothing happened. I've the curl error again.

The symbolic link doesn't work :

sudo ln -s /usr/lib/libssl.so.1.0.0 /lib/i386-linux-gnu/libssl.so.1.0.0
ln: impossible de créer le lien symbolique «/lib/i386-linux-gnu/libssl.so.1.0.0»: Le fichier existe

The file /lib/i386-linux-gnu/libssl.so.1.0.0 exists.

Fabrice

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .