Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After an improper shutdown, my Windows 7 stopped booting and instead displayed "The boot selection failed because a required device is inaccessible. Error code: 0xc000000e" When I plug the drive in as an external on a working computer, I get the message that the drive needs to be formatted. If I go into disk management, it lists that partition type as RAW.

However, when I use disk tools such as TestDisk 6.14, I am able to list and copy files. Also, the partition type is recognized as NTFS. This leads me to believe that there must be a way to fix this so that Windows can recognize it just like TestDisk does.

I also ran chkdsk /r on the drive and got the message "Unable to read the Usn Journal $J data stream".

Any ideas, anyone? FYI this is an SSD drive.

share|improve this question
    
Please head back to Server Fault, register your account, then use the same login here to associate your accounts. –  slhck Feb 18 '13 at 19:22
add comment

migrated from serverfault.com Feb 18 '13 at 14:05

This question came from our site for professional system and network administrators.

1 Answer

Have you tried to recover the partition table? Quoting the TestDisk wiki:

It's now possible to write the new partition structure.

Note: The extended partition is automatically set. TestDisk recognizes this using the different partition structure.

enter image description here If all partitions are listed and only in this case, confirm at Write with Enter, y and OK.

Now, the partitions are registered in the partition table.

Update: If you open the disk with gparted or some similar tool, do you see the partitions as unformatted, or do you see the entire disk as unpartitioned space?

My guess is that you somehow lost the partition table, but your partitions might still be intact. In that case, try to:

  • make a backup of the entire disk, if possible, with a tool like dd
  • recreate the exact same partitions as they were on the disk
  • leave the partitions un-formatted, do not create a file system on any of them
  • use dd again to write the part of the backup image that corresponds to the lost NTFS partition directly to the /dev/sd??
  • try to mount the partition now

(Sorry, the above only applies to Linux systems, not sure how to do all that on a Windows machine.)

If the above did not work (and for that matter, if none of the things worked from the TestDisk tutorial), that probably means that the partition itself is damaged as well, in which case there's not much I can help you with, best is to try and save the files you need.

share|improve this answer
    
Yes I did try but it did not work. –  user200269 Feb 18 '13 at 18:51
    
@blizz: Before you attempt anything else with this drive, I would recommend that you use TestDisk or similar to copy your important files to another one. That way if you are forced to reformat, at least you won't lose anything of value. –  Karan Feb 18 '13 at 19:56
    
Already did that, thanks. Trying to avoid formatting and reinstalling programs since i dont have product keys for everything. –  blizz Feb 18 '13 at 20:03
    
Ok well thanks anyways. I tried many things but was unable to make that partition accessible from Windows. I did at least back the files up using TestDisk before formatting. I also updated the original question with the boot error so that it can be found by more people who may want to learn about TestDisk. –  blizz Feb 19 '13 at 0:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.