Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 320 GB WD hard disk and recently some folders got corrupted. I tried to use HDD Regenerator to fix the hard disk. While it was repairing, it was interrupted.

Now the hard disk won't mount and no drive letter shown, yet it is visible as an external device in the Safely Remove Device menu. When I use that tool again it says "Master Boot Record is corrupted". In Disk Management it asks to initialize the disk, but that doesn't work.

How can I fix the MBR and recover my hard disk?

NB: chkdsk and scandisk don't work as it doesn't have a drive letter.

share|improve this question
add comment

1 Answer 1

If you're not against using a LiveCD, download a copy of Ubuntu, either burn it to a disc or to a USB, then boot the computer from the CD or USB.

Once booted into the environment, you may then plug in the USB drive. Find out which device it is that you want to fix the MBR of by running lsblk. (Look here for more tips)

Install lilo (sudo apt-get install lilo), and you can fix the MBR by running sudo lilo -M /dev/sdx mbr. (sdx here is the drive you found after running lsblk above)

(Note, all of the commands are run from Terminal in Linux.)

share|improve this answer
    
I do have Ubuntu installation If i install lilo will it remove GRUB and corrupt my Ubuntu installation? My external drive status is zero byte free and full..It only had one partition can I get previous disk structure? Thanks in advance.. –  Ruwinda Mihiran Feb 18 '13 at 15:35
    
According to this post in 2004 (lists.atrpms.net/pipermail/atrpms-users/2004-June/000509.html), having both installed will not change your settings unless you manually set LILO to be your boot loader. Fixing the MBR will not change the disk structure. –  Kruug Feb 18 '13 at 15:37
    
Ok I will try and Let you know thank you.. –  Ruwinda Mihiran Feb 18 '13 at 15:43
    
Problem still exists and when trying to install mbr using lilo it gives input/output error and I tried many other tools and none of them worked out, at least Ubuntu shows it as "sdc" , In Disk utility in Ubuntu shows its 2TB yet it's only 320GB drive ,there are many question like this but none of them help me out –  Ruwinda Mihiran Feb 18 '13 at 17:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.