Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had problems using OpenVPN on Ubuntu 11.04. I am not able to connect at all. I see there are some outstanding bugs related to this that also affect 12.04. Can anyone recommend a different linux flavor that can run OpenVPN without issue? My vpn service is vyprvpn. I am able to connect using my android phone and my imac. It is only my linux machines running Ubuntu that cannot connect.

share|improve this question
1  
If you are having problems with the version of openvpn that comes with your distribution, then your options are to upgrade it manually, or find a distribution that has the version you want. You have chosen the latter approach, so it is just a case of checking the packages of common distributions to see which one carries the version you are after. –  Paul Feb 18 '13 at 21:11
    
Migrating to another distribution just because something (seems) not to work is just getting into much bigger trouble later on. Fix this, get involved with the bug squashers for your distribution, even compile your own from source as a desperate measure. –  vonbrand Feb 18 '13 at 21:22
add comment

2 Answers 2

Fedora 17 runs OpenVPN beautifully (I can't speak for Fedora 18 though, I've heard it has some issues). I use it every day and I rarely have problems. Occasionally I have to restart the service by running sudo systemctl restart openvpn@client.service, but mostly it just works.

I am surprised however to hear that it isn't working for you on Ubuntu. I have friends that run OpenVPN on Ubuntu 12.04 without problems, so it may be a configuration issue for either you or the server. If it is a config issue, switching distros will just waste your time. If it is bugs related to Ubuntu though, switching may be worth while.

Good luck!

share|improve this answer
    
I think fedora and ubuntu have common network applet do you try connect vpn with? –  Yurij73 Feb 18 '13 at 22:44
    
I am not sure of the exact product, but I believe it is IBM Mobile Connect. –  Freedom_Ben Feb 19 '13 at 19:57
    
I have tried connecting through the applet. I watch the logs and it there are some issues there. I am on ubuntu 11.04 –  user102023 Feb 23 '13 at 1:58
    
You may check your firewall as David said. best way by gui firewall app. –  Yurij73 Feb 24 '13 at 7:43
    
Other way to conf your fw is by console. which is your proto - udp or tcp and which is your private network adress? change the next strings accordingly. /sbin/iptables -I INPUT -p udp --dport 1194 -j LogAccept; /sbin/iptables -I OUTPUT -p udp --sport 1194 -j LogAccept; /sbin/iptables -I FORWARD -s 10.0.1.0/24 -d 192.168.1.0/24 -j LogAccept; /sbin/iptables -I FORWARD -d 10.0.1.0/24 -s 192.168.1.0/24 -j LogAccept –  Yurij73 Feb 24 '13 at 7:44
show 1 more comment

I run OpenVPN on a number of different Linux based distros, (including, among others, Ubuntu 12.04 and CentOS5) and without needing to do manual restarts (and for long periods) - without issue. Are you sure the problem is not your configuration or firewall on your box ?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.