Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently noticed that on websites that require multiple small requests, such as google maps, I have a tons of timeout issues. Similarly, browsing is not as smooth as it is with other devices connected to the same router (wirelessly).

The funny thing is that for large files the throughput is really good. I can torrent a file and fill the connection limit (about 15Mb/s) without any issue. Similarly, I can copy from my file server on the network at 45MB/s flawlessly.

But the worst of it is that as soon as I connect via the wirless adapter of my ASUS P8Z77-V motherboard everything run noticeably better, including google maps. Unfortunately I can only get up to 300Mb/s on wifi, which means that transfers to my file server are now as low as 5MB/s.

I have a BiPAC 7800 gigabit router directly connected to my PC using a cat 6a cable. I tried to (stress) ping servers out there, but I never got a packet loss. Since my motherboard has two LAN controller I also tested both: no dice. :(

Does anyone have any idea of what could be wrong?

Btw, I am using windows 7 professional.

share|improve this question
    
Very good question. My best guess would be it has to do with how your router is distributing connection. –  Griffin Feb 18 '13 at 23:48
    
Is there a standard config I can check to verify that? Btw, QoS and WMM are not enabled. –  Nova Feb 19 '13 at 8:42

2 Answers 2

Have you by any chance enabled jumbo frames in your network card configuration? (through the hardware configuration in device manager)

Network and Sharing center -> Click adapter -> Properties -> Configure -> Advanced

I have Gigabit Ethernet on all my home computers, and a switch capable of jumbo Ethernet frames with a payload up to 9KB. Switching this on is great for massive transfers, like backing up my Steam GCF's to my home server, but I have noticed it did slap the performance of what should be quick and small web pages like Google. My Internet connection is 80Mbps down / 20Mbps up, so Google should certainly be instant.

If you've got this setting enabled you may want to try it switched off instead, as your jumbo Ethernet frames will almost certainly have to be segmented by your router in order to deliver it to the Internet. Standard Ethernet frames only have 1.5KB of payload, and I doubt much of the Internet's backbone has a lot of support for larger Ethernet frames.

share|improve this answer
    
Well, I have recently tried two things at once: enabling WMM on the router and Jumbo frames to 9k. Ever since I did that it seems to be working much better. I have also the suspect that the router might playing a role in it, i.e. by degrading the connection if it has been on for a while. I will do a bit of experimentation over the weekend, but your suggestion might very well be the correct answer! –  Nova Feb 21 '13 at 23:39
    
Also if all of your LAN nodes are capable of Gigabit Ethernet you can safely disable flow control. That will give you a bit of performance. –  Adambean Feb 22 '13 at 5:31

I know it sounds silly, but, you haven't said it...

Update drivers!

If that doesn't work... Downgrade drivers.

share|improve this answer
    
That's one of the first things I have tried (upgrading): it didn't seem to help. Plus, the two network adapter on my motherboard are from different chipset (RealTek and Intel), and both exhibit the same issue. –  Nova Feb 21 '13 at 23:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.