Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It seems I've come across an issue that is unique to using a particular laptop with a particular router.

From an initial observation it would appear the laptop is having trouble obtaining an IP address (it can hang for a while), and once it appears to have one there is no communication between the laptop and router at all (I can't ping the default gateway).

Full list of things I've tried:

  • Changing the SSID
  • Changing the MAC of the adapter (seems to prevent all network connections?)
  • Manually setting the IP Address
  • ipconfig /renew
  • Resetting the router

I've tested all other combinations (that is other routers and other laptops) and they all seem to work. It's even stranger that the laptop has worked fine for months with this router - then stopped working seemingly overnight.

The screen looks like this for a while, and can eventually claim to connect:

Attempting to obtain IP via DHCP

but the network connection icon never lights up:

No connection

I believe this problem began when my USB wireless adapter began to fail with 'Windows cannot recognise this device'. Since then I've been using a different adapter which exhibits this problem. Would it be possible something got corrupted?

I've captured some interesting Event Viewer logs that don't seem to have any pattern, and I'm not entirely sure these are symptoms of the problem. Not all occur on each connection attempt:

Event Type: Warning
Event Source: Server
Event Category: None
Event ID: 2504
Date: 18/02/2013
Time: 23:08:23
User: N/A
Computer: LAPTOP
Description: The server could not bind to the transport \Device\NetBT_Tcpip_{AC06A4D3-4497-47CD-BE17-1290E77BAAAC}.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: aa 05 00 00
ª...

Event Type: Warning
Event Source: Dhcp
Event Category: None
Event ID: 1007
Date: 18/02/2013
Time: 23:12:43
User: N/A
Computer: LAPTOP
Description: Your computer has automatically configured the IP address for the Network Card with network address 0016E35B2BA9. The IP address being used is 169.254.0.148.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 00 00 00 00
....

Event Type: Warning
Event Source: BROWSER
Event Category: None
Event ID: 8021
Date: 18/02/2013
Time: 23:13:17
User: N/A
Computer: LAPTOP
Description:
The browser was unable to retrieve a list of servers from the browser master \HEATHER-PC >on the network \Device\NetBT_Tcpip_{AC06A4D3-4497-47CD-BE17-1290E77BAAAC}. The data is the error code.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 35 00 00 00 5...

Output of ipconfig /renew (after a wait while it was 'Waiting for network to be ready'):

C:\Documents and Settings\Matthew>ipconfig /renew

Windows IP Configuration

No operation can be performed on Local Area Connection while it has its media disconnected. An error occurred while renewing interface Wireless Network Connection 2 : unable to contact your DHCP server. Request has timed out.

Any help / pointers are much appreciated.

share|improve this question
    
Can you see any logs on the router? Try doing 'ipconfig /release' followed by 'ipconfig /renew' –  James Feb 19 '13 at 3:16
    
@James - I tried to look at the router logs however they wouldn't show (I was getting unescaped javascript on the screen) - I'll try again later. I'll try the /release and /renew and let you know what happens. –  m.edmondson Feb 19 '13 at 8:30
    
@James - I've tried your suggestions, see question for details. –  m.edmondson Feb 19 '13 at 19:01
    
I've also changed the MAC address (however this seems to break all network connections). –  m.edmondson Feb 19 '13 at 22:55
1  
@medmondson My best guess would be to uninstall the driver for the wireless adapter, reboot, and reinsert it so that Windows reinstalls it –  James Feb 19 '13 at 23:37
add comment

2 Answers

Something has definitely gone awry with the configuration on either your router or your laptop. I have seen this before and after several hours of tinkering, the only thing that seemed to help was to completely reset the wireless router, and reinstall the wireless adapter on the computer.

As far as "reinstalling" the wireless adapter on the computer, I'm not referring to simply installing drivers over the ones that are already there; You need to uninstall all drivers and software associated with it, and then reinstall the drivers... Preferably the latest version available.

Hope that helps.

share|improve this answer
1  
Shudder There must be some rational explanation... and a decent solution. Perhaps the WiFi access point/router acquired a MAC filter that disallows this particular machine? A prank by some neighboring geek perhaps? Some miscreant sneaked into it? –  vonbrand Feb 19 '13 at 2:55
    
@vonbrand - I thought this also, but after looking at the MAC filtering on the router everything is disabled –  m.edmondson Feb 19 '13 at 8:32
add comment

Well it turns out there was one thing I missed; turning off encryption completely. As soon as I did this the laptop connected fine.

Since this is a reasonably old laptop I can only imagine the adapter (or driver) can't handle WPA2, so I've reverted to WEP for the time being until I can either get it updated or get a new adapter.

Thanks for your help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.