Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If this belongs on serverfault I sincerely apologize.

I have an nVidia motherboard used to RAID 1 (mirror) two 250GB drives. It normally shows me a screen that indicates the status of the array is "healthy" during boot. Now, I just rebooted and the status was "degraded." Obviously something to wrong, but what does that specifically mean? Is one or both of the drives failing (the array isn't dead yet, I can still access my files on it) or is something else going on?

I do have another array that appears as healthy.

Any thoughts would be greatly appreciated!

Edit: One additional thing of note, instead of one mirrored array being displayed in the array manager, it is now showing two mirrored arrays, each with one drive.

Edit 2: I actually found the answer else where. Somebody else had a similar problem where essentially two broken arrays had been created out of one for no obvious reason. It was fixed by blowing away one of them and then adding that drive back to the other array and rebuilding it.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You should consider "degraded" akin to words like "crashed" or "broken". It doesn't mean you've lost data, but it does mean that your RAID has failed and it is the features of the RAID (like mirroring) that are currently preventing you from catastrophic loss.

See this article for further analysis of your problem Data Recovery for RAID, which says:

First determine if the problem is caused by the underlying RAID mechanism.
If it is not, follow the simpler recovery procedures for an ordinary drive.

In any case, make sure you have backup!

share|improve this answer

Since you have 2 drives in RAID1, "degraded" means that one of your drives has failed.

You will need to figure out which drive has failed, and replace it. The RAID software or firmware should tell you which drive is bad. Once you've installed the new drive, you'll need to go into the RAID configuration and add the new drive to the array. After that, the RAID1 will rebuild on its own and should again show "healthy" status.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.