Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I routinely use Excel for TDT and other formats. I've never had a problem getting Windows to open .tdt files in Excel by default; in Windows 7, it's right-click | Open with | Choose default program... | Browse | C:\Program Files\Microsoft Office\Office##\Excel.exe | Open.

However, I recently installed Excel 2013, and the above technique no longer works. Even after navigating to Excel and hitting Open, Excel does not appear in the list of programs.

So I guess I need to add the association in the registry somewhere. I see the list of extensions in HKCR, but the entry for CSV implies that Excel has special handling for that extension; anyway, copying the keys and value from .csv to .tdt has no impact. I also see HKCU\Software\Classes.tdt, with a "Content Type" of "application/vnd.ms-excel", but that doesn't seem to be doing anything.

Finally, there's HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.tdt\OpenWithList. There's a value for EXCEL.EXE and several others, but only two of these (7-Zip and Notepad++) appear in the GUI. I can choose either of these two apps. However, it doesn't seem to have changed the content of either registry key, so there's no obvious entry to change.

Googling around, I see plenty of discussions about using the GUI, but the registry doesn't come up as often, and no two seem to be the same.

share|improve this question
add comment

1 Answer

Did you try to right-click the TDT file, click "Properties", and under the General Tab where it says "Open with:", click the "Change". Browse to the location in Program Files > Office > Office[x] > excel.exe

That should work.

I would also try changing it to something else (Notepad, for example), reboot, and then change back to Excel - see if that works.

share|improve this answer
    
This should work. I wouldn't bother messing with the registry entries. Actually, I'd recommend against it for OP unless he really knows what he's doing. –  David Zemens Feb 19 '13 at 20:29
    
No, the Properties tab doesn't work any better than the right-click | Open with menu. I've rebooted since setting it to Notepad++, with no change. –  Jon of All Trades Feb 19 '13 at 22:08
    
Did it work when you set it to Notepad++? What about after setting it back to Excel and then rebooting again? –  Joshua Feb 20 '13 at 14:59
    
It works with Notepad++, that is files now open in Notepad++ by default. The issue is that I can't set the default to Excel, as it does not appear in the menu even after browsing to the actual .exe. –  Jon of All Trades Feb 20 '13 at 18:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.