Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two machines I'm trying to use Synergy (both are running 1.4.10) with:

  • MacBook Pro with Mountain Lion 10.8.2
  • PC with Windows 7 Enterprise (SP1)

The MacBook has a 2nd monitor attached and it sits to the right (though this seems to make no difference). The PC has just one monitor, which sits to the right of the 2nd monitor on the MacBook, as so:

+-------+ +-------+    +------+
|MacBook| |MacBook|    |Win7PC|
|Native | |2nd Mon|    |      |
+-------+ +-------+    +------+

I've got the two machines to connect and have keyboard/mouse (k/m) control working in one direction. My issue is that I cannot get the client k/m to control the server. I would prefer to have the PC be the server, but I have tried both ways to no avail.

If I make the MacBook the server, then I can use the MacBook's k/m to control the Windows 7 PC, but cannot use the Windows 7 PC's k/m to control the MacBook. If I change it up and make the Windows 7 PC the server, then I can use the PC's k/m to control the MacBook, but cannot control the PC with the MacBook's k/m.

On the PC side, I have tried setting all the Synergy *.exe's on the PC to run as Administrator on the compatibility tab (as I saw this suggested elsewhere) and I have explicitly run the app as Administrator. I also tried both "Process mode" settings; Service and "Desktop (legacy)". When using the "Service" mode, I also tried the "Elevate" checkbox.

On the MacBook side, when I run the Synergy GUI application (from Applications folder where I "installed" it), I notice that I cannot get Synergy to even start unless I go into Preferences and set the "Process mode" to "Desktop (legacy)". After switching to "Desktop (legacy)" I am able to start either the client or the server and can get the two machines talking... I just can't use the client's k/m to control the server! FWIW, I also tried running the synergyc or synergys programs with and without sudo directly from a shell... same results.

I've turned logging to DEBUG2 on both sides and I don't see any messages on the client or the server when I use the client mouse and drag the cursor to the edge of the screen. Again, doesn't matter if the client is the PC or the MacBook... no messages every show up in the logs when the client mouse is dragged to the edge of the screen.

I've searched for people with similar problems and haven't found anything. I'd appreciate any assistance!

Here's the server config I use from the MacBook:

section: screens
   MacBook:
      halfDuplexCapsLock = false
      halfDuplexNumLock = false
      halfDuplexScrollLock = false
      xtestIsXineramaUnaware = false
      switchCorners = none 
      switchCornerSize = 0
   Win7PC:
      halfDuplexCapsLock = false
      halfDuplexNumLock = false
      halfDuplexScrollLock = false
      xtestIsXineramaUnaware = false
      switchCorners = none 
      switchCornerSize = 0
end

section: aliases
   MacBook:
      MacBook.domain.local
   Win7PC:
      Win7PC.domain.local
end

section: links
   MacBook:
      right = Win7PC
   Win7PC:
      left = MacBook
end

section: options
   relativeMouseMoves = false
   screenSaverSync = true
   win32KeepForeground = false
   switchCorners = none 
   switchCornerSize = 0
end
share|improve this question

1 Answer 1

up vote 0 down vote accepted

This is not a feature of Synergy as of version 1.4.10.

http://synergy-foss.org/spit/issues/details/105/

share|improve this answer
    
Wow, I can't believe I didn't find that explicitly stated anywhere. I could swear I used Synergy years ago like this but I guess not. Thanks, @Tanner! –  Nathan May 30 '13 at 19:38
    
Would be a pretty sweet feature to have. –  Tanner May 30 '13 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.