Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo Z370 which has touch enabled buttons for mute and volume. The mute button randomly acts as if being pressed turning the sound on and off rapidly.

I've discovered that if I reboot the problem goes away for a while, after it starts muting/unmuting this seems to be the only way to stop it (either that or actually leave your finger resting on the mute button, but that really isn't an option).

Failing to find a solution to the problem (I've tried lenovo's forums without success, where I also noticed more people having the same problem) I want to find the driver that handles those buttons and uninstall it, or if that is not possible, use any other solution for permanently disabling the mute button that doesn't involve the use of force :)

How can I discover which driver is being used to handle those buttons? Or how can I disable them permanently?

Thanks, Rui

share|improve this question
    
Have you looked in BIOS? Sometimes laptops have settings in there for those extra buttons. –  Vladimir Oselsky Jan 13 at 13:17
    
@SaUce There are no bios settings for these buttons –  Rui Jan 13 at 14:01

3 Answers 3

up vote 1 down vote accepted
+100

Workaround

As you can see from the official Drivers and software page, there's nothing related to the keyboard. Apparently Windows can handle those media keys directly without any extra drivers. Since uninstalling some drivers is not an option, you could disable the mute/unmute key so that Windows should simply ignore it:

  1. Open a command prompt as administrator.

  2. Type the following command and press Enter:

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout" /v "Scancode Map" /t REG_BINARY /d 000000000000000002000000000020e000000000 /f
    
  3. Log off or restart Windows to apply the changes.

If that doesn't work, it means your laptop keyboard doesn't use standard media key scancodes, and you'll have to resort to AutoHotKey or similar, as suggested by @DBZ_A.


A bit of explanation

Quoting Wikipedia:

A scancode (or scan code) is the data that most computer keyboards send to a computer to report which keys have been pressed. A number, or sequence of numbers, is assigned to each key on the keyboard.

Since Windows 2000, the Scancode Map registry value can be used to remap a key to another or disable it entirely. The scan code mappings are stored in the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout

In the Keyboard Layout key, the Scancode Map value must be added. This value is of type REG_BINARY (little Endian format) and has the data format specified in the following table.

Start offset (in bytes) | Size (bytes) | Data
---------------------------------------------------------------------
                      0 |            4 | Header: Version Information
                      4 |            4 | Header: Flags
                      8 |            4 | Header: Number of Mappings
                     12 |            4 | Individual Mapping
                    ... |          ... | ...
           Last 4 bytes |            4 | Null Terminator (0x00000000)

The first and second DWORDS store header information and should be set to all zeroes for the current version of the Scan Code Mapper. The third DWORD entry holds a count of the total number of mappings that follow, including the null terminating mapping. The minimum count would therefore be 1 (no mappings specified). The individual mappings follow the header. Each mapping is one DWORD in length and is divided into two WORD length fields. Each WORD field stores the scan code for a key to be mapped.

Source: Keyboard and mouse class drivers

In this case there's only one mapping: the media mute key (scancode 0xe020). It is remapped to 0x0000, which means it gets disabled.

Scan code values can be easily found through programs like SharpKeys.

Further reading

share|improve this answer
    
Can you provide some more information about what that line actually does? For example what is the scancode map and how did you find "000000000000000002000000000020e000000000" ? –  Rui Jan 19 at 13:03
    
@Rui: I've updated my post. –  and31415 Jan 19 at 16:22
  1. Are you sure this is not a hardware issue (button being pressed?)
  2. As a workaround , please try this Disable some extra keys on keyboard in windows
share|improve this answer
    
I'm pretty convinced it is a hardware issue. Since I really don't care about those touch sensitive buttons, I was interested in finding the driver for them and uninstalling it. I'll give AutoHotKey a try. –  Rui Jan 13 at 14:08
    
AutoHotKey works perfectly, thanks, I'll wait for another answer that doesn't involve installing additional software, if no one comes with one I'll give the points to you –  Rui Jan 13 at 18:59

I would say it sounds like a driver issue as you have stated. With this said I would recommend that you go to Lenovo's site and download your laptop's drivers from their site and reinstall all of them. That should fix your problem.

If that doesn't work, you can go to your device manager via the control panel and look to see if all of your drivers are working properly, if you find the culprit you can disable it from there as well. If there are any drivers with a yellow sign next to it or any unknown drivers you should either download the applicable driver (recommended) or you should disable it.

You can also try installing something like realtek sound drivers.

Hope this helps.

share|improve this answer
    
There is nothing wrong in the device manager. This really seems to be a hardware issue, it happens more often when the laptop is plugged in. –  Rui Jan 13 at 14:06
    
Also, I have all the latest drivers. I've tried to selectively uninstall them and check if any would be just for the touch buttons, but no. Probably it comes bundled with one of them –  Rui Jan 13 at 14:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.