Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some .mkv 1080p videos but VLC can't play them smoothly.

If I open the Task Manager, I can see that CPU is at 100%, because VLC uses as much as it can (95% or more).

Then, I wonder

  • Is it a CPU problem, because it's slow?
  • Is it a GPU problem because it isn't so good, so the CPU must do all work?
  • Is it a player problem, because it's a VLC bug, or it doesn't use the right codec, or doesn't support hardware acceleration?
  • Is it a OS problem, because XP it's too old?

I have:

  • CPU: DualCore AMD Athlon 64 X2, 2200 MHz (11 x 200) 4200+
  • GPU: nVIDIA nForce 6100-430
  • Player: VLC v2.0.5
  • OS: Windows XP SP3
share|improve this question
    
Thanks for asking this question, I wouldn't have the below answer without it!! Thanks :) –  Anmol Saraf Sep 19 at 23:28

3 Answers 3

up vote 4 down vote accepted

VLC uses the CPU heavily, you can find other players that utilize the GPU better. Daum PotPlayer, SMPlayer, Gom Player. LifeHacker Link

share|improve this answer
    
PotPlayer uses 100% CPU too, but it plays the video smoothly, thanks –  Oriol Feb 20 '13 at 0:21
    
VLC can offload decoding to the GPU where supported by drivers and video card - wiki.videolan.org/VLC_GPU_Decoding. If your video is slow, you probably need to find video acceleration drivers for your Video card (or get a new one if your card does not have GPU acceleration) –  davidgo Feb 20 '13 at 9:06
    
Tried the first one - Daum PotPlayer and works amazing! Thanks. Still have to check if it is eating 100% cpu as first comments but still all popular players like vlc, realplayer and many failed to play my youtube downloaded mkv file but this one worked flawless!! Thanks once again :) –  Anmol Saraf Sep 19 at 23:26
    
cpu keeps jumping between 28 to 44 percent. I can always take it considering the quality it gives. –  Anmol Saraf Sep 19 at 23:32

Your GPU doesn't support accelerated HD decoding. More recent GPUs can handle HD decoding and are much more efficient at this than CPUs.

share|improve this answer
1  
Thanks, I will take it on account when I update my computer. But meanwhile, I prefer Ryan E's answer, it's cheaper :) –  Oriol Feb 20 '13 at 1:07

I had the same problem. I saw the solution on another site and it worked for me. The 1080p file actually played fine in windows media player, so I knew it wasn't my computer. The solution is to change the file cache to a larger value, say 2000, in vlc player. You can find the setting in tools/preferences with "all" checked in show settings. Then go to Input/Codecs, where near the bottom of the window it says advanced/file caching. Set it to 2000 and save, then restart VLC player. Wahla, it worked for me. It took me a second to find the show settings at the bottom, and then it took a little while longer to find the file caching, but once I found it, it worked perfectly. You might also want to reset VLC player, just in case you messed it up really bad, and then increase the cache value. Good Luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.