Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded to Windows 7 Ultimate (without reinstalling, an actual upgrade) and now I'm experiencing some really annoying mouse lag in Chrome. It seems to happen most often when there is a Flash element on the page, though that's not always the case.

I have a Windows Experience base of 7.5 (I just re-ran it), 7.7 in desktop and gaming graphics, and Skyrim still runs fine. I ran an Intel chipset update and re-installed my Catalyst drivers (I uninstalled them first), and I don't have any available Windows Update. I've also re-installed both Chrome and Flash, and I've disabled all of my Chrome extensions. Nothing has helped.

What might be causing this very annoying issue, and what might I do to fix it, short of reformatting?

Thank you.

share|improve this question
add comment

7 Answers

I've also experienced weird issues with Chrome when the Shockwave player was present on a page. I disabled Chrome's Shockwave/Flash player and use what's installed on the machine, because sometimes they conflict. You should try disabling Chrome's built-in Flash player.

share|improve this answer
    
Thanks for the suggestion, but it didn't help. –  Mike Pateras Feb 21 '13 at 11:43
add comment

Mike,

  1. Disable all flash plugins in Chrome
  2. Close all web browsers
  3. Uninstall both Flash and Shockwave
  4. Open the Services snapin. Find the service "Tablet PC Input Service". If it is running stop the service, then change the 'Startup type' to "Disabled". Click OK. (Ignore this step if you are using a tablet PC)
  5. Launch Chrome go to ABOUT:FLAGS and enable GPU compositing.
  6. Close all web browsers
  7. Reboot
  8. Launch a web browser other than Chrome and install Flash (and shockwave if needed) from Adobe's website.
  9. Close all web browsers (this is only because some browsers cache some writes)
  10. Launch Chrome and verify the flash plugin installed correctly.

Don't skip browser closing/reboot steps! This will resolve your mouse lag. It did for me.

Afterthought: if using any OEM or 3rd party mouse software with a USB mouse verify update rate is greater than 300 Hz (this won't fix the problem, but can hide it). MouseRate7 and other utilities can do this.

share|improve this answer
    
Don't you read existing answers first? –  harrymc Feb 22 '13 at 16:43
1  
Sure do. All were incomplete. –  OCDtech Feb 22 '13 at 18:00
1  
They were far from incomplete in the referred article. To copy everything would have made me an enormous answer. It's anyway not good netiquette to repeat a part of someone else's answer, just in more details. –  harrymc Feb 22 '13 at 20:21
    
A productive answer with 10 steps is not possible by omitting one when all 10 must be completed in the specific stated order. –  OCDtech Feb 22 '13 at 20:31
    
Sadly it didn't help anyway. –  Mike Pateras Feb 23 '13 at 4:31
add comment

It seems that you have built-in Chrome's Flash enabled. It may have one/two versions that will conflict with the default Flash. Therefore they will cause lag when viewing Flash content.

In order to use only the default Flash do the following:

  • Type chrome://plugins/ in Chrome's address bar
  • Check for Shockwave Flash versions that point to Chrome's folder. Disable it/them.
  • Default Flash (pointing to System32) should be enabled.
  • Restart the browser and you should be all set.

Watch this video from other device apparently. It shows what I wrote above.

share|improve this answer
    
No luck. One of the first things I tried. –  Mike Pateras Feb 23 '13 at 4:34
add comment

Some advice :

  • Check running processes for CPU intensive processes
  • Try turning off the anti-virus
  • Close some tabs if too many are open, especially ones running Flash Player or Shockwave

Some advice from this article :

  • Try disabling the builtin Flash Player and Shockwave of Chrome and install Adobe Flash Player while all browsers are closed.
  • Disable the Tablet PC Input Service
  • Clear the Chrome browsing history, cache, etc. You may also use CCleaner and Glary Utilities for thorough cleanup.
  • Disable the Super Fetch service
  • Disable the AdBlock extension

Advice from Adobe :

  • Delete all Flash Player browsing data
  • Remove Flash Player cache
  • Disable Flash Player hardware acceleration
  • Report the issue to the Flash Player forum

[EDIT]

I found that this is a known bug in Chrome :
Issue 117032: Significant delay on 'mousemove' event with GPU acceleration from Mar 6, 2012.

The problem is related to hardware-accelerated GPU animation, disappearing when the GPU is not used. However, turning off the use of the GPU is, to my way of thinking, even worse than mouse lag.

My advice is therefore, if the mouse lag is unsupportable, to use another browser, at least until this bug is fixed.

share|improve this answer
    
Disabling Super Fetch service in Windows ? This can't be good. –  Devid Feb 22 '13 at 17:11
    
Tried it all. No luck. –  Mike Pateras Feb 23 '13 at 4:33
2  
@MikePateras: If nobody comes up with an answer that works, in your place I wouldn't reformat and reinstall Windows, especially since you don't know if this will solve the problem. I would abandon Chrome first, chalking this problem up to a Chrome bug on your hardware setup. –  harrymc Feb 23 '13 at 6:43
    
See also my edit above - it seems like Chrome has a problem with your GPU. –  harrymc Feb 24 '13 at 10:18
add comment

Lag associated with every mouseover event fixed on my ageing D620 Win7Ult64 (no GPU): go to ABOUT:FLAGS or chrome://flags and set GPU compositing from Default to Disabled

share|improve this answer
    
Tried it. No luck. –  Mike Pateras Feb 26 '13 at 12:17
    
Did the trick for me –  Boris Callens Apr 22 '13 at 10:46
add comment

Check which version of the plug-in you have installed in Chrome. For Chrome and Firefox you need the NPAPI version. (click details button top-right on plug-ins page). PPAPI may appear if flash was installed via ie download - this was my problem. To fix - browse to Flash download page using Chrome browser download and re-install flash.

More details on plug-in type here: http://acrobatninja.blogspot.co.uk/2013/02/flash-player-in-acrobat-family.html

share|improve this answer
add comment

This sounds like a problem with enabled mouse acceleration. Go from Control Panel to Mouse Properties, select the Motion tab and uncheck Disable acceleration in games if it's enabled.

Occasionally, mouse acceleration can cause reduced cursor tracking speed in Chrome. The reason it seems to kick in when you've got Flash content running is probably because Flash Player settings has an option to Enable hardware acceleration. Historically I suppose it's because of the prevalence of Flash games where mouse acceleration could be handy, but can cause some of these side-effects.

It does seem to only occur with certain versions - I recall there being similar instances with a particular 18.x version of Chrome, so a rollback is an option, but try disabling mouse acceleration first before resorting to a downgrade.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.