Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to set an NTFS partition to be auto-mounted in Linuxmint 14 KDE. I have already added command in /etc/fstab file as below:

/dev/sda1 /media/MyDrive ntfs defaults 0 0

After saving the file when I tried to mount it myself, by clicking on the drive name on left panel in Dolphin file browser, it shows errors as below:

An error occurred while accessing 'Home', the system responded: The requested operation has failed.: Error mounting: mount exited with exit code 1: helper failed with: [mntent]: warning: no final newline at the end of /etc/fstab mount: only root can mount /dev/sda1 on /media/ikrz/MyDrive

I have opened fstab file as an administrator (root user), so there should be no issue with administrative authenticity.

It was working fine when I was using Linuxmint 14 MATE.

Please help.

I am having one more trouble which is related to user permission questioned at stackoverflow.com.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

If you want to automount it with a normal user, you have to add that flag to the fstab:

/dev/sda1 /media/MyDrive ntfs defaults,user 0 0

Also the error tells you there's no final end line in /etc/fstab, so open the file, get to the end of the last line, hit enter and save it.

share|improve this answer
    
I tried as you said, but An error occurred while accessing 'Home', the system responded: The requested operation has failed.: Error mounting: mount exited with exit code 1: helper failed with: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at tuxera.com/community/ntfs-3g-faq/#unprivileged. Then I linked my user account with other groups like users and root using User Management. But did not work out. –  user117146 Feb 21 '13 at 13:09
    
NTFS is kinda tricky, but the link has almost all the information, just rebuild it and use setuid-root to grant permissions to your user. –  Peter Feb 22 '13 at 8:48
    
Ok. I rebuild the ntfs-3g and made it setuid root. And now it is auto-mounting at start up with full read and write permission. Thank you. But it is still showing error while I remount it after unmounting once as 'only root can mount' it. So if I unmount it accidentally I have to relogin or restart my system to get mounted by root. –  user117146 Feb 24 '13 at 12:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.