Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a tri-boot laptop, and two of the operating systems I have are Ubuntu 12.10 and Windows 8. On Windows 8, I can access the WLAN, however whenever I restart the computer it defaults to having wireless turned off, and I have to turn it on so it can connect to the WLAN.

On Linux, I have the same problem but I do not know how to turn the wireless on, so I cannot connect to the internet while on Ubuntu.

If you need any additional info or want to ask a question, just throw me a comment.

share|improve this question
    
If you continue to have issues, you should specify what hardware you have. –  Michael Hampton Feb 21 '13 at 2:07
    
In Linux, what is the output of iwconfig? –  nerdwaller Feb 21 '13 at 2:46
    
@nerdwaller It says eth0 - no wireless extensions lo - no wireless extensions –  Anton8000 Feb 21 '13 at 15:49
    
Try lspci | grep -i net to see your wireless card, research which drivers are required (and linux compatibility) and you can see which were requested in the OS by lsmod. Sounds like it isn't even up (so either no driver or not enabled on boot), so I would probably try ifconfig set wlan0 up (if I remember right). What does the Network Manager applet say when you open it? –  nerdwaller Feb 21 '13 at 18:09
    
@nerdwaller It was working a few days ago, just about 30 hours before. –  Anton8000 Feb 22 '13 at 21:10
add comment

1 Answer

up vote 3 down vote accepted

Try using rfkill to re-enable your wireless radio.

For example:

rfkill list

to see your wireless devices, and

rfkill unblock 0

to re-enable the device at index 0.

Note that if a device is "hard blocked" then you cannot re-enable it with rfkill. You have to flip the hardware switch, and possibly reboot the computer, to re-enable the device.

share|improve this answer
    
Hold on, I have a problem. It is still saying: Offline: You have been disconnected I have unblocked it and it is no longer soft blocked. If you could help, much appreciated. –  Anton8000 Feb 21 '13 at 14:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.