Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using cygwin and windows NTEmcas. In cygwin console, how to open a file by NTEmacs ?

share|improve this question
    
I don't use NTEmacs so I don't have a simple answer. It would help to see the command you type and the response you get. The most likely reason I can think of is that NTEmacs is not in your PATH. NTEmacs will probably also fail if you give it a full Cygwin path name as the file name argument. To fix that, use cygpath (see "man cygpath") either directly on the command line or in a wrapper script. A wrapper script can also avoid the need to alter your PATH by using the full path name of NTEmacs. Again, the more information you provide, the better answer you will get. – garyjohn Feb 21 '13 at 18:12
    
I believe there is no "native" emacs port, all use (parts of) CygWin. Your best bet is to use the CygWin one, and its emacsclient(1) (if NTEmacs doesnt' provide one). – vonbrand Feb 22 '13 at 2:40

I got the solution.

  1. put Following to the .emacs, to make the emacs server start automatic

    (server-start)

  2. in cygwin add one alias:

    alias e='cygstart /d/p/ntemacs24/bin/emacsclientw.exe'

  3. then in cygwin console, you can open a file in emacs by

    $ e wp-settings.php

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .