Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Gateway P-6860fx Bios Options Greyed/Grayed Out

I had bios boot password protected.

The other day I booted into a corrupted windows and it wanted to repair. I powered off with power button to reboot.

Upon rebooting the bios didn't ask for a password to boot.

Eventually I reinstalled windows but then I began to wonder if I have and infected bios.

So I attempted to reset to default bios configuration but it's greyed out and so is the supervisor password selection. In fact almost everything is greyed in bios except for user password and some minor selections.

I can change user password but not boot order etc..

So I flashed to a newer bios but the greyed out issue is stilled there with the new flashed bios.

I then tried to use winflash to wipe the bios before flashing the new bios but windows crashes to a memory dump.

Windows seems to boot fine and work fine but there's this nagging issue of how did my bios boot password get overridden and why can I not modify major settings in the bios anymore.

I then removed the cmos battery for 10 minutes but the issue was still there so I shorted the connectors of the cmos battery, and no joy (. I the left the cmos battery out over night but that didn't reset the bios either.

I tried some debug codes to clear cmos but non of them worked.

I contacted Gateway but my laptop is out of warranty.

So now I'm stumped.

Any help at all would be very appreciated.

Thanks in advance

share|improve this question
add comment

1 Answer

There may be a jumper to reset the BIOS password. Also, it sounds like you may be connecting to the BIOS in some kind of user mode rather than as the admin. I'm not sure how you would get in to BIOS as the admin, but that might be the problem if your BIOS supports multiple levels of access. (It could certainly explain the limited access to options.)

share|improve this answer
    
Thank for your reply. It's a laptop and so far I haven't seen a jumper around or near the cmos yet. The level of access is the problem. I had full access before with boot password protected. Now when I access the internet I'm getting all sorts of weird requests from my firewall of svchost.exe wanting access through ports that I know shouldn't be in use. It's looking like some kind of bios malware Bios malware is on the rise as it's becoming increasing vulnerable due to tracing technology that is being subverted for malware use. –  user201240 Feb 21 '13 at 23:56
    
As I suspected this a bios virus which can be erased with a motherboard jumper that clears cmos but as of yet I don't know if gateway has one for this laptop. Here's a link for further info. community.mcafee.com/thread/39954 –  user201240 Feb 22 '13 at 16:18
    
Update: New information, blog.webroot.com/2011/09/13/… about new bios based attacks along the lines of previous post that used similar tactics to fix infections. –  user201240 Feb 22 '13 at 22:35
    
@User201240 - you should probably post the info as your own answer and then mark your own answer. It sounds like it is probably the most correct answer. –  AJ Henderson Feb 22 '13 at 22:37
    
duh, what was I thinking, thx AJ! Question was answered in the above posts citing the webroot and McAfee communities. community.mcafee.com/thread/39954 and blog.webroot.com/2011/09/13/… –  user201240 Feb 22 '13 at 23:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.