Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7. I recently installed Adobe Acrobat Pro 9, which also installed Adobe's PDF Print Driver, allowing me to print documents directly to a PDF when I go to File --> Print.

Unfortunately I have found that when printing vector-based graphics from Silverlight applications Adobe's PDF Print driver scales down the content of each page to fit into just the upper left quadrant of each page, leaving the right quadrant and bottom half of each PDF page blank. I'm not sure why it is doing this (printing it to paper does not do this, printing it to XPS does not do this, etc.). I have tried another freeware PDF printer driver and it prints the content on the entire page (as expected), although it seems to produce lower-quality documents with artifacts around the letters and so on.

I am wondering if there has been an update or fix to this issue by Adobe, but I'm not sure on how to do the following:

  • Determine what version of the printer driver I am using
  • Download and install the latest version

I've tried doing to Devices and Printers and right-clicking on the printer driver and choosing both Printer Properties and Properties, but I don't see any version numbers. And while Adobe's Printer Drivers page lists the most recent version as 4.2.6, I worry I'm looking in the wrong place as the page looks very dated (talking about software for Windows 95/98, for instance).

share|improve this question
    
Have you tried a recent version of Acrobat Pro by chance? –  Ramhound Feb 21 '13 at 18:52
    
At this point in time, I doubt if Adobe is doing much work on Acrobat Pro 9.0 since the latest version is XI (11). Short of upgrading, your best bet would probably be to go to adobe.com and download a trial version for their latest software and see if it works better. –  martineau Feb 21 '13 at 19:15

2 Answers 2

More than likely this has nothing to do with the driver, and is probably related to the print preferences that you have set for the virtual printer.

In Devices and Settings, open the Printing Preferences for the PDF printer and make sure you have the correct paper size for the document you're printing, and that any shrink-to-fit and zoom options are turned off.

share|improve this answer
    
Also confirm that these settings are still the same when you go into the actual print dialogue. –  Moses Feb 21 '13 at 18:40
    
FWIW, this issue happens when I print from a Silverlight 5 application that sends vector-based data to the printer (rather than bitmap-based data). As far as settings, I have it set to Letter document size. –  Scott Mitchell Feb 21 '13 at 18:49

Enable/Disable Adobe Acrobat Distiller setting:

  • Allow PostScript File to override Adobe PDF Settings
  • Preserve overprint settings
  • Resize Page And Center Artwork For EPS Files

Adobe Acrobat Distiller setting

View printer name and PPI setting 1:

wmic PRINTER get Name, VerticalResolution

View printer name and PPI setting 2:

wmic PRINTERCONFIG  get Name, VerticalResolution, PrintQuality

Many applications take the printer settings from different places. In most cases it is better if VerticalResolution, PrintQuality setting 2 correspond VerticalResolution setting 1.

Printer settings default and ...

share|improve this answer
    
I have the three Distiller setting checkboxes already checked. When I try to run your wmic command get 1200 for all three settings (VerticalResolution for PRINTER, VerticalResolution for PRINTERCONFIG, and PrintQuality for PRINTERCONFIG). Not sure if that's good news or bad news. :-) –  Scott Mitchell Feb 25 '13 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.