Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am missing the "Change display language" link in my Control Panel as shown in the screenshot below:

1

I can't reach language properties in any way, like Start Menu search, changing the view of control panel etc. What is wrong with it?

share|improve this question
1  
1) If you have the Local Group Policy Editor (Start / Run / gpedit.msc), under Computer Configuration\Administrative Templates\Control Panel\Regional and Language Options, are any of the options such as Restricts the UI language Windows users for all logged users enabled? 2) Try running sfc /scannow from an elevated command prompt. 3) Run Windows\System32\intl.cpl and see if you can change the display language from the Keyboards and Languages tab. –  Karan Feb 22 '13 at 1:06
    
@Karan Isn't that a full-fledged answer? –  BenjiWiebe Feb 22 '13 at 1:22
1  
@BenjiWiebe: I guess... Not sure if any of the suggestions will definitely solve the OP's issue though, so thought perhaps I'll wait till he responds with results. Also, Devid seems to have hit upon an important point which might explain why the option's missing. –  Karan Feb 22 '13 at 1:41
    
1.None of the options were enabled and they have been set to "Not Configured".2)After running this command it gave me this response: "verification 30% complete. Windows Resource Protection could not perform the requested operation"3)It asks me to Install display language language! I think i Would not have problem with this option,The problem is running of this window and a link that has vanished! –  user201329 Feb 22 '13 at 14:32
add comment

1 Answer

Do you have Windows 7 Ultimate ? If not that is the problem, cause only in Windows 7 Ultimate or Enterprise you can change from Control Panel the display language. In other Windows 7 versions you will need to hack the registry.


If you are running Windows 7 Ultimate but can't see the options under Control Panel try first to install MUI (Multilingual User Interface).

  1. Start -> All Programs --> Windows Update --> Optional Updates.
  2. Open optional Updates and go to the section Windows 7 Language Packs.
  3. Tick the Multilingual User Interface (MUI) you want and click OK
  4. Proceed with Install Updates

Windows Optional Updates Note If the optional update links cannot be found, click Check online for updates from Microsoft Update to search the optional updates. Windows Search Online for Updates

To change the display language, follow these steps:

  1. Click Start, and then type Change display language in the Start Search box.
  2. Click Change display language.
  3. In the drop-down list that appears, select the language that you want, and then click OK.
  4. Log off for the changes to take effect
share|improve this answer
2  
+1 Good catch, perhaps this is the answer. Ultimate and Enterprise have this feature. For other versions, this might help. –  Karan Feb 22 '13 at 1:46
    
I'm running Windows 7 Ultimate Service Pack 1. Could it solve the problem? –  user201329 Feb 22 '13 at 14:34
    
@user201329 Then try to do the following: youtube.com/watch?v=NwdmukiE7xM –  Devid Feb 22 '13 at 15:02
    
@user201329 if you upgrade to Windows 7 Ultimate you should be able to change the display language from the control panel. –  Devid Feb 22 '13 at 15:04
    
@Devid But i'm not! –  user201329 Feb 22 '13 at 20:20
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.