Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've moved from using Office 2007 on Windows XP to using Office 2007 on Windows 7.

I frequently open word documents (a mixture of .doc and .docm) through hyperlinks on an intranet. With Word 2007 documents I've noticed that there's a dialog in the background that simply says "opening" and displays the url of the document I'm opening. If I cancel that dialog box the document opens immediately.

I've tried it logged in as different users on different machines and exactly the same thing happens, they open straight away on Windows XP and take forever (with the hidden dialog) on Windows 7.

This was fine on Windows XP but since moving to Windows 7 it takes forever for the documents to open.

Any ideas?

Thanks

share|improve this question
    
I would try a different browser. If you have permission, disable your AV / Firewall and see if that changes anything. –  Dave Rook Feb 22 '13 at 9:50
    
Sadly tried using alternative browsers and the same thing occurs. Opening the url directly from Word also causes the same issue to occur. It's the same AV client on all the machine, and the firewall is disabled. The 'hidden' dialog box is a Word one. –  Norman Feb 22 '13 at 10:18
    
Does this issue only occur on your machine or on every machine with W7? –  Dave Rook Feb 22 '13 at 10:42
    
Every machine with Windows 7 –  Norman Feb 22 '13 at 10:46

1 Answer 1

Try this: Open IE, click on Tools (if it doesn't appear, press ALT), Internet Options. Then the Advanced tab. Now, uncheck "check for publisher certs" and uncheck "check for server certs"

Alternatively, the reason could be:

This issue occurs because Windows Explorer tries to obtain detailed information about the remote share and about the file that you are opening. This operation may take a long time over a slow connection.

You can make the change by updating the registry, but sadly this would be by PC (so not sure if this is a realistic option).

Changing the registry Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 How to back up and restore the registry in Windows

Add the
SuppressionPolicy
DWORD value to the following registry key:
HKEY_CLASSES_ROOT\*\Shellex\PropertySheetHandlers\CryptoSignMenu
To do so:
    Click Start, and then click Run.
    In the Open box, type regedit, and then click OK.
    Locate and then click the following registry key:
    HKEY_CLASSES_ROOT\*\Shellex\PropertySheetHandlers\CryptoSignMenu
    On the Edit menu, point to New, and then click DWORD Value.
    Type SuppressionPolicy, and then press ENTER.
    On the Edit menu, click Modify.
    Click Hexadecimal, type 100000 in the Value data box, and then click OK.
Add the
SuppressionPolicy
DWORD value to the following registry key:
HKEY_CLASSES_ROOT\*\Shellex\PropertySheetHandlers\{3EA48300-8CF6-101B-84FB-666CCB9BCD32}
To do so:
    In Registry Editor, locate and then click the following registry key:
    HKEY_CLASSES_ROOT\*\Shellex\PropertySheetHandlers\{3EA48300-8CF6-101B-84FB-666CCB9BCD32}
    On the Edit menu, point to New, and then click DWORD Value.
    Type SuppressionPolicy, and then press ENTER.
    On the Edit menu, click Modify.
    Click Hexadecimal, type 100000 in the Value data box, and then click OK.
Add the
SuppressionPolicy
DWORD value to the following registry key:
HKEY_CLASSES_ROOT\*\Shellex\PropertySheetHandlers\{883373C3-BF89-11D1-BE35-080036B11A03}
To do so:
    In Registry Editor, locate and then click the following registry key:
    HKEY_CLASSES_ROOT\*\Shellex\PropertySheetHandlers\{883373C3-BF89-11D1-BE35-080036B11A03}
    On the Edit menu, point to New, and then click DWORD Value.
    Type SuppressionPolicy, and then press ENTER.
    On the Edit menu, click Modify.
    Click Hexadecimal, type 100000 in the Value data box, and then click OK.
Add the
Flags
DWORD value to the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\SCAPI
To do so:
    In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\SCAPI
    On the Edit menu, point to New, and then click DWORD Value.
    Type Flags, and then press ENTER.
    On the Edit menu, click Modify.
    Click Hexadecimal, type 00100c02 in the Value data box, and then click OK.
    Quit Registry Editor.

There is also a Group Policy option

Adding a Group Policy Besides the direct registry modifications that are described in the "Changing the registry" section, you can also resolve this issue by using a Group Policy. Administrators can control which shell extensions can run by using the Approved key and the EnforceShellExtensionSecurity policy. The SuppressionPolicy value is tied to the EnforceShellExtensionSecurity policy. You can add this policy to enable the modified shell behavior.

To do this, follow these steps:

Click Start, click Run, type Gpedit.msc, and then click OK.
Under User Configuration in the left pane, expand Administrative Templates, expand Windows Components, and then click Windows Explorer.
In the right pane, double-click Allow only per user or approved shell extensions, click Enabled, and then click OK.

Source

share|improve this answer
    
I was actually have a similar issue within my network and the steps dramatically decreased the load time for Office 2007 & 2010. Thanks! –  Moses Feb 22 '13 at 16:53
    
Sadly this didn't work. It's over a fast ethernet LAN, and, as I'm going to update the original posting to reflect, it only effects Word 2007 documents. Word 2003 documents and all other file formats (for example PDF) all open as expected. –  Norman Feb 27 '13 at 9:03
    
I have another thought as I've just experienced something very similar. For me, the latest driver caused a huge throttle, this coupled with the data above may mean I've added 1+1 and got 3 but, can you install a different / older network driver and see if that affects it? –  Dave Rook Mar 15 '13 at 10:16
1  
Managed to solve it. Didn't notice but what was happening was that .docm files were associated with IE, while .doc files were associated with Word. Changed that and both sorts now opening speedily. –  Norman Mar 26 '13 at 13:21
    
Glad you got it working. Feel free to answer your own question! :) –  Dave Rook Mar 26 '13 at 13:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.