Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a doubt in UN-mounting the drives in Linux.

Whenever I open any drives in system its shortcut/image will be shown in the desktop. To remove that I need to right click on it and select unmount.

Then only that shortcut disappears. This always happens. So whenever I open any drive all of them will be there in desktop. What I need is this shouldn't happen. What can I do for that?Can anyone help?

I am using Ubuntu 12.04. Previously I used 10.10 then also same problem was there.

share|improve this question
    
This is a duplicate of a question at askubuntu: askubuntu.com/questions/27392/… I would recommend posting Ubuntu specific question there in the future. –  Eric G Feb 23 '13 at 22:17
1  
@EricG Ubuntu questions are on topic here—it's perfectly fine to post them on Super User. We don't migrate on-topic questions away; see Is it okay to inform users to stop promoting Apple.SE when a question is fine to stay here? (same for Ubuntu) –  slhck Feb 23 '13 at 22:40
    
@slhck, the bigger issue was it was a duplicate question, but its not on the list for dup questions in th flag; I see this question is generally enough to work here too. –  Eric G Feb 23 '13 at 22:48
    
@EricG Ask Ubuntu and Super User are absolutely unrelated in that regard. If there are questions about the same things on both sites, so be it. It's not an issue, really. –  slhck Feb 23 '13 at 22:50
add comment

2 Answers

up vote 1 down vote accepted

This was addressed on Ask Ubuntu a few times, here is a post with some screenshots that may be useful:

  1. Press Alt-F2 and enter gconf-editor.
  2. Navigate to apps/nautilus/desktop.
  3. Deselect volumes_visible. gconf-editor

If you want your other volumes to be visible, you will have to add them manually:

  1. Right click on desktop and click 'Create Launcher...'
  2. Change the type to 'Location'
  3. Change the name to suit you.
  4. Browse for the volume.
  5. Change the icon to the 'block device' icon at /usr/share/icons/YOUR_THEME/devices/48/block-device.svg
  6. Click OK.

    launcher

share|improve this answer
    
but in nautilus folder only preference is present.I think i need to install something else.can u tell me what is it? –  Sjk Feb 25 '13 at 11:32
add comment

This can be removed by Changing a value in Gnome-configuration-Editor

Run gconf-editor

if dont have it install it by apt-get install gconf-editor

after opening go to apps->nautilus->desktop and uncheck

share|improve this answer
1  
but which value? –  LiuYan 刘研 Feb 23 '13 at 17:46
    
@sreevisakh In nautilus folder only preference folder is present in my system.I think i need to install something else.can you tell me what is it? –  Sjk Feb 26 '13 at 12:02
    
if you cant find them use the commandline tool gconf-tool2 to set the values –  Sreevisakh Mar 11 '13 at 17:58
    
@Sreevisakh while entering that command it showing command not found!!! –  Sjk May 27 '13 at 17:27
    
try sudo apt-get install gconf-editor –  Sreevisakh May 30 '13 at 6:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.