Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I read through a lot of ubuntuforums threads and tried out various things. Still freshly installed Ubuntu 12.04 (64-bit, 3.2.0-38) hangs on reboot/shutdown after the line "All processes ended within 2 seconds".

What I tried so far without success

  • remove plymouth (replace by a dummy package)
  • kill almost all processes / unload almost all modules / unmount all devices manually before boot
  • uninstall network manager, modem manager, bluetoothd, ureadahead etc.
  • tried several boot parameters (acpi=, reboot= etc.)
  • disabled ipv6
  • ifdown'ing the ethernet devices

Killing everything with Alt+SysRq+e and Alt+SysRq+i doesn't help either.

The logs don't show anything unusual.

Rebooting with Alt+SysRq+b or reboot -f does work, but it's not how I'd like it to.

I'm out of ideas of where to look and how to debug. Please help with some advice!

share|improve this question
add comment

1 Answer

try change in /etc/default/grub following line:

GRUB_CMDLINE_LINUX="reboot=p"

or

reboot=b

or something else according to https://www.kernel.org/doc/Documentation/x86/x86_64/boot-options.txt

then

sudo update-grub
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.