Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop is installed with Windows 7 SP1 Ultimate , 64 bit version.

Recently, I went to the university, which only provides ipv6.

I've built a OpenVPN Tunnel to handle ipv4 traffic, but I've found when I enable OpenVPN Tunnel, all domain with ipv6 only will failed but numeric address (like 2001:a:b::c) works.

I've tried microsoft fix me 50441, which change settings to prefer ipv6 over ipv4, doesn't work. nor does changing the priority of ipv6 prefixpolicies(change ::ffff:0:0/96 to the lowest).

When I use wireshark to monitor my traffic, I've found that my laptop did only A record lookup instead of AAAA record. How could I fix it?

EDIT: I've added some information which may be useful for find out the problem.

C:\Users\Jack-YYF>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : LAPTOP-JACK
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Mixed
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter wlan1:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
   Physical Address. . . . . . . . . : 7E-E4-00-1E-71-2F
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter tun1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-Win32 Adapter V9
   Physical Address. . . . . . . . . : 00-FF-E6-D6-8B-5F
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 172.16.0.6(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.252
   Lease Obtained. . . . . . . . . . : Friday, February 22, 2013 23:00:20
   Lease Expires . . . . . . . . . . : Saturday, February 22, 2014 23:00:19
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . : 172.16.0.5
   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       8.8.4.4
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter tun0:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : gogo6 Virtual Multi-Tunnel Adapter
   Physical Address. . . . . . . . . : 02-50-F2-00-00-01
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter eth0:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
   Physical Address. . . . . . . . . : C8-0A-A9-93-B3-54
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:da8:8001:3301:954d:8bd5:599c:97ba(Preferred)
   Temporary IPv6 Address. . . . . . : 2001:da8:8001:3301:1475:d65e:e534:d27a(Preferred)
   Link-local IPv6 Address . . . . . : fe80::954d:8bd5:599c:97ba%13(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.147.100.16(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::223:89ff:fe34:adb6%13
                                       10.147.100.1
   DHCPv6 IAID . . . . . . . . . . . : 398985897
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-D2-97-60-78-E4-00-1E-71-2F
   DNS Servers . . . . . . . . . . . : 2620:0:ccc::2
                                       2620:0:ccd::2
                                       202.120.224.6
                                       202.120.224.26
   NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter wlan0:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
   Physical Address. . . . . . . . . : 78-E4-00-1E-71-2F
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8180:f992:bd60:2d75%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.137.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 293135360
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-D2-97-60-78-E4-00-1E-71-2F
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter btn0:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . : 00-27-13-D7-7F-EC
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
share|improve this question
    
It's likely that IPv4 is Windows' preferred choice over IPv6. Network and Sharing center -> Change adapter settings -> Advanced menu -> Advanced settings At the bottom of this form move IPv6 above IPv4 and it should have the preference. –  Adambean Feb 22 '13 at 21:15
    
@Adambean Thanks for your comment. I have tried your solution, it works! –  Yifu Yu Feb 23 '13 at 2:52
    
@Adambean Yes, you should post this as an answer. –  Michael Hampton Feb 23 '13 at 4:04
    
Hi Mike, glad to here it worked out. I wasn't sure if it would work so I didn't post it as an answer. Have done now :) –  Adambean Feb 23 '13 at 13:46
    
Sorry, *Yifu Yu –  Adambean Feb 23 '13 at 14:36

1 Answer 1

up vote 1 down vote accepted

It's likely that IPv4 is Windows' preferred choice over IPv6.

Network and Sharing center -> Change adapter settings -> Advanced menu -> Advanced settings

At the bottom of this form move IPv6 above IPv4 and it should have the preference.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.