Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I set to open up with certain defaults. I like a specific theme (Homebrew) with a default size of 140×50.

However if I click the close icon (red X) to close the window and then go to open up another shell (Terminal), the shell settings go back to the default black text on a white background.

I noticed an oddity that seems to be related to it: The dock icon of Terminal indicates that after I closed the terminal window, Terminal is still running (even though the shell has been closed).

If I right click on the dock Terminal icon and exit, the dot goes away, indicating that in fact the instance is now no longer running. Now, when I open a new instance I get my correct settings.

What am I missing here? It seems as though when my terminal is closing it isn't really closing right. How can I fix this so it closes right and the actual instance is closed when typing exit from the shell or when I click on the red X?

share|improve this question
In OS X, when you close an application window, the application doesn't necessarily have to quit entirely. This is the case for Terminal, and there's no way to change that really. How do you "open up another shell", exactly? And if you say, "settings go back to the default", do you mean the black text / white background defaults, not your defaults? – slhck Feb 22 '13 at 15:53
When I open another instance, I go to the doc and click on the Terminal icon. When I say "Settings go back to the default", yes.. the black text / white background defaults. Thanks for your quick reply. – Dale Feb 22 '13 at 15:56
Just to be sure: Have you set the default theme by clicking Default in the Profiles, like shown here? Maybe try deleting the Terminal preference file in ~/Library/Preferences/ (note that you'll lose your custom settings). As a workaround you can always quit Terminal with ⌘Q instead of closing the last tab. – slhck Feb 22 '13 at 16:03
The DEFAULT is what I didn't have set. I had the STARTUP flag set but not the DEFAULT. After setting that, the Terminal icon now always comes up right. Thanks. – Dale Feb 22 '13 at 16:42

1 Answer 1

up vote 7 down vote accepted

You have set the “On startup, open:” preference in

Preferences > General

which only selects the profile for the new window automatically created when opening Terminal with no other windows restored.

Instead, set the default profile in

Preferences > Profiles

which applies to terminal windows you create after Terminal is open.

Note that when the startup-window profile is the same as the default profile, changing the default will affect the startup-window profile as well. If you change the startup-window profile to something else it will remain as-is if you later change the default profile.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.