Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Oracle's VirtualBox (4.2.6r82870) on Windows 7 and I'm trying to list the partitions on my uSD card which is inserted in the computer as drive "E". I pulled open the Window's Computer Management->Disk Management window and I can see E is mounted as "Disk 1"

So initially I tried this command:

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe internalcommands listpartitions -rawdisk \\.\PhysicalDrive1

but I got back an error:

VBoxManage.exe: error: Cannot open the raw disk: VERR_ACCESS_DENIED

I read this was because I couldn't use this feature unless I was running as admin, so I found the VBoxManage.exe program, right clicked on it and selected Properties->Compatibility and picked to "Run this program as an administrator".

Now when I issue the same command it sits there for awhile then spits back:

VBoxManage.exe: error: Failed to create the VirtualBox object!
VBoxManage.exe: error: Code CO_E_SERVER_EXEC_FAILURE (0x80080005) - Server execution failed (extended info not available)
VBoxManage.exe: error: Most likely, the VirtualBox COM server is not running or failed to start.

What is the proper way to get this program to run correctly?

share|improve this question
    
Run cmd as administrator and then use VBoxManage. And as far as I remember, VirtualBox cannot operate on mounted drives. –  gronostaj Feb 22 '13 at 16:26
    
@gronostaj - Yes, opening the command prompt as an admin fixed the other window opening issue, but that was really just a side effect. The overall problem of the command not working remains. –  Mike Feb 22 '13 at 16:37
    
That error makes it sound like you've got a problem with the installation. Try repairing or reinstalling. Can you run the VirtualBox GUI ok? –  heavyd Feb 22 '13 at 16:43
    
@heavyd - Yeah, I've been using the GUI and a number of it's mapping fetchers with no issues for months now, I just decided that I wanted to use the command line tool to check the partitions and once I ran that as Admin I started seeing this error. The GUI still works. –  Mike Feb 22 '13 at 16:52
    
Have you tried unmounting the card? I mean unassigning a drive letter. –  gronostaj Feb 22 '13 at 16:59
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.