Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm pretty sure this doesn't belong on serverfault. Anyway, I'm confused with DynDns. Its supposed to change the IP address whenever your IP address changes, but for anyone to access the host I have to make it point to my router's global IP address, which I have to forward port 80 to my computer's current local IP Address, and the port forwarding won't automatically change when the IP address changes. Any help? Thanks. By the way, I'm on an iMac, with Aiport Extreme (AEBS) router.

share|improve this question
up vote 6 down vote accepted

It sounds like you might be a litle bit confused as to the difference between DynDns and port-forwarding.

DynDns provides hostname resolution for your public IP address, or the "global" IP address of your router. Whenever your ISP assigns you a new public IP, the DynDns client (typically on your router) updates the DynDns servers.

Port-forwarding takes care of mapping an open port on your public IP to a private IP address on the local network. Most routers do not have an easy way of updating port-forwarding rules to deal with changes in your dynamic private IPs. Typically the easiest way to work around this is to set up your server with a static private IP so that the router will always forward port 80 traffic to that one IP.

share|improve this answer
Ohh Its the global router ip that changes, that dyndns deals with? Ohh ok now I understand.. But I don't think I need to make the local ip static because Airport Extremee always tries to use the same IP, so far the local IP for my mac has never changed. – Mk12 Oct 15 '09 at 2:26
If you never have any other device come onto your network, you will probably be okay. However, if you have more than one device on your network that gets its address from DHCP you could get assigned a different one. It may not be likely, but possible. – heavyd Oct 15 '09 at 2:29
+1 deleting my answer it it essentially duplicates what you say but with less detail than in here – A Dwarf Oct 15 '09 at 2:41
Actually, it's Chris who does. +1 there too ;) heavyhead answer is just as good though – A Dwarf Oct 15 '09 at 2:43
Yes, it is definately using DHCP, and I also have 5 other devices that connect through the router via WiFi. – Mk12 Oct 15 '09 at 19:53

For DynDns to work automatically, you need a router that supports dynamic DNS. I'm not familiar with the Airport, but in my D-Link router, there is a Dynamic DNS page where I put in my login information. The router then automatically updates my DNS settings every time my public IP address changes.

If your router doesn't support that feature, you'll need to run a client program on your computer that does the same job.

Regarding port forwarding, you need to make your computer use a static IP address. Some routers support creating an IP reservation, which causes the router to assign the same IP address to the same computer each time. Otherwise, you have to manually configure your computer to use the same IP address.

share|improve this answer
I downloaded the DynDns Updated client for mac.. But actually, I'm pretty sure Aiport Extreme uses same IP because I know it's dynamic but I never remember it changing.. So does that mean I don't need dyndns? Other then for a domain name? – Mk12 Oct 15 '09 at 2:21
It seems like you're saying you don't need port forwarding to use DynDns.. but to make my website public, dyndns needs to point to my global router ip, which has to port forward to my mac's local ip, right? – Mk12 Oct 15 '09 at 2:23
Yes, for computers that I have ports forwarded, I keep them with static IP addresses outside of the DHCP address range. – Stephen Jennings Oct 15 '09 at 2:23

If you're running Snow Leopard, you'll need to use this workaround as well for the updater:

We also have a troubleshooting guide on our site, in case you can't connect to your server/device, but I'm only allowed to post one hyperlink. If you go to our site and do a search for "can't connect" it will be the first result listed.

share|improve this answer
Thanks, I already found out about that. However it still doesn't automatically start it on startup.. – Mk12 Oct 19 '09 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .