Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Acer Aspire 4253 laptop with windows 7 and fedora 17 installed.

Recently Windows encounters errors while installing device drivers for storage devices. It fails to install drivers for pen drives, portable hard disks and MMC, but other devices like iPod, USB modem are installed without any error.

The device manager shows the devices in disk drives but with an alert symbol. It says in properties

A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)

Can anybody help in resolving this issue?

Where could I find alternate drivers for storage devices?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Here are 3 things you can do which may resolve your issue.

  1. Run Malware Bytes or SpyBot S&D to make sure there isn't anything else (malware/spyware/adware) messing with your system.

  2. Update definitions and run a complete virus scan. An additional free online scan at eSet just to make sure its all gone might be a good idea.

  3. Once you know the system is clean, open an elevated command prompt and run SFC /SCANNOW to run the System File Check. When it is done, reboot.

share|improve this answer
    
Already done those things but of no use –  Shankar Feb 22 '13 at 20:38
    
It would be helpful to have that information in the question so we know what you've already tried. Please edit your question to include ALL the details so people aren't posting answers that won't help you. –  CharlieRB Feb 22 '13 at 20:40

The answer is to find the missing/invalid drivers for your devices on the web and install them. After you do that, Windows 7 will find them just fine when you need them.

share|improve this answer
    
Tried. Windows finds the drivers but the problem occurs while installing. –  Shankar Feb 22 '13 at 19:29
    
@ShankarC - Sounds like a system integrity problem, in other words, your Windows installation is corrupt. –  Ramhound Feb 22 '13 at 19:40
    
Any solution to resolve this issue ? –  Shankar Feb 22 '13 at 19:43
    
Find the drivers OUTSIDE of letting windows do this, their drivers are sometimes bad. Go the manufacturer website and get their drivers and install them manually. –  mdpc Feb 22 '13 at 20:18
    
Problem not with drivers , problem with windows\ –  Shankar Feb 22 '13 at 20:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.