Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My mini-jack input is broken, so my computer(HP pavilion dv6 Notebook) thinks there is headphones plugged in at all times. If I physically press lightly on the headphone intput location, speakers start working again. Even if headphones are plugged in, the cable needs to have tension in a certain angle to work. This is extremely annoying! Fixing it wud cost more than the computer is worth, and I can't afford a new one worth buying. I'm running Windows 7 with IDT audio. In all different options I've found, the speakers and headphones seems to have the same muscle. If I deactivate one, i deactivate the other. In fact, I cant find different options for them at all. Does anyone know a way I can force my computer to ONLY play through the speakers, even if headphones are detected? Not both at the same time, ONLY speakers!

share|improve this question
    
Are you sure fixing it would cost more than the computer is worth? It's very plausible the jack can be repaired by poking the insides with a screwdriver. If so, no respectable computer shop would charge any serious money. –  Marcks Thomas Feb 22 '13 at 20:17
    
You do not say how the input is broken. If a part of the plug is lodged in it, try tweezers. –  Jan Doggen Apr 1 at 18:26
    
Did you tried this –  Renju Chandran chingath Jul 10 at 19:04
    
Did you ever find a solution to this? I appear have the exact same problem (also Windows 7 and IDT audio, I even have to push on the audio jack to get it to function correctly just like you). My only variance is that my computer has two audio jacks (and only one of them are malfunctioning). –  tad Dec 5 at 14:49

3 Answers 3

I've never tried this as a solution to this problem, but you could try disabling the headphone output device in the playback device manager.

  1. Right click the speaker icon in the tray and click playback devices.
  2. Right click and show disabled devices.
  3. Right click the headphone output and disable.

If this doesn't work you might need third party software. As @ShankarC suggested, try using the Realtek audio manager (drivers on CNET) to disable the headphone output.

share|improve this answer

If you use Realtek to manage audio, you will have options for disabling headphones.

share|improve this answer
1  
Drivers for above answer can be found here: download.cnet.com/Realtek-AC-97-Driver-Windows-Vista-Windows-7/… –  Moses Feb 22 '13 at 19:40

Harald,

Check out the screenshot.

Open [Control Panel] > [Sound] > [Manage audio devices]

From there, click the device you wish to activate, and click [Set Default]. I wanted to switch between speakers and permanently plugged-in headphones, so I threw a shortcut to the [Manage audio devices] window directly onto my desktop (see image). You may use this to easily switch between the devices.!

http://www.rhwdesigns.com/SolarEclipse/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.