Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is driving me mad....when I add a 'Connector' to my diagram it is a certain Connector type (Association, Composition, Aggregation, etc...)

I have to select one of those types. And those types have a default arrow type. Even though I go into 'Format Shape' and change the drop down for 'Begin Arrow type' and 'End Arrow type' nothing changes.

How do I get the appearance I select in the 'Begin Arrow type' and 'End Arrow type' drop-downs to be reflected on the screen?

share|improve this question

5 Answers 5

Yea same here but I found it after a while of looking about.

The default styles are laoded based on the kind of project you start with. So I started with UML so it loads styles based on UML. But you can go and change everything about the object as pictured.

enter image description here

share|improve this answer

Insert your arrow as usual and then highlight it.

Once this is completed, navigate to the Home tab > Shape Styles, click the line dropdown and select the type of arrow you need.

share|improve this answer

The availability of the arrow types depend on your shape selection.

You can select business->brainstorming and association line from there for a double sided arrow and I'm sure there are similar arrows in other shape groups.

An arrow with both sides is not available for all types of drawings.

share|improve this answer

I am no expert on this but a similar problem here suggests that the style constraint may prevent manual changes to lines. This link suggests how to disable the style constraint, but for Visio 2010:

In Visio 2010 the Styles have been deprecated and are not on any of the toolbars or right click options. Here is what I did: 1. Choose File > Options > Quick Access Toolbar (You could also customize a ribbon for this.) 2. From the drop down choose Commands Not in the Ribbon 3. Scroll down and select Style. (Do not choose Style... as this displays a dialog. 4. Choose Add to add the Style option drop down to the Quick Access toolbar.

Now you have the ability to remove the style from the Relationship shape.

To change the Relationship shape: 1. Select the shape 2. From the Quick Access Toolbar select the Style drop down and choose No Style 3. Right click the Relationship shape and choose Format Line 4. Set the line begin and line end to the desired format

share|improve this answer

I had a similar problem recently when I wanted to add a page with a simple ERD to a diagram that originally started as a UML project. No matter what begin/end selector I chose, it just wouldn't apply.

It seems, as ppumkin indicated that some default styles are loaded when you select your project, with this come some constraints though, and it seems in my case the UML project prevents choosing line endings. I was able to fix this by opening the shape sheet and navigating to the Line Format section. You'll see that the begin arrow and end arrow values are set to "Guard(0)", e.g. set it to beginning/end arrow 0 and don't let it change. Just replace Guard(0) with zero and then you'll be able to set the arrow to what ever you want normally.

Unfortunately it only changes the one line, so you'll have to copy and paste your unlocked line to use else where, or keep fixing the shape sheet ... so not an ideal solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.