Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Actiontec PK5000 DSL modem and have Port forwarding setup to point to my web server. I have a static IP. I have a weird situation where if I try to access the web server through the static IP I can only see it externally but when I try to access it internally through the static IP it will not resolve. What would cause this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This is "normal" behaviour. Its actually a complicated thing to ask your router to do to ask it to take in an external IP address, translate and NAT it, then send it back into your internal network. It can be setup to do this but that takes some extra configuration generally speaking.

There are some general solutions to this problem:

  1. Use a HOSTS file, see (http://en.wikipedia.org/wiki/Hosts_(file)) to override DNS and instead provide the local address of the host internally
  2. Setup the router to SNAT it back internally. Not all devices will support this
  3. Setup your DNS to return a different result internally to externally. This is sometimes called split-horizon DNS

The first option is your easiest path from here.

You can use services like http://www.downforeveryoneorjustme.com or http://www.browsershots.org to confirm the website is remotely viewable, or remote desktop to a machine outside your network.

share|improve this answer
    
what would the host file look like to set it up I added my ip address but its still not resolving –  Yamaha32088 Feb 23 '13 at 4:50
    
I don't know what operating system you are using, but assuming Windows 7 try reading an article such as howtogeek.com/howto/27350/… . Read, try and work it out, then if you start a new question. –  mechcow Feb 24 '13 at 8:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.