Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows XP 32-bit OS on my computer, which has been acting strange lately: the system REFUSES to shut down, standby or even hibernate. Sometimes, the system even randomly reboots with a split second blue screen. Luckily, I found the cause of the problem: one process uses so much RAM, it leaks into system processes.

I have an HIS Radeon 6670 graphics card, and all the latest drivers for it. However, the process "ati2evxx.exe" is using 743M of my 3GB of RAM. Now I understand there is a restriction to how much ram a process can have, especially in 32-bit systems, but Windows XP should have a relatively tiny system footprint.

Is there a way I can disable this process? I looked it up and all I saw was that it was a hotkey poller. (why would an event listener take up so many resources??!) Any help is appreciated.

share|improve this question
    
Run your favorite antivirus and malware removal programs. Update the system. Google for that name, it could be known malware. –  vonbrand Feb 23 '13 at 5:20
    
@vonbrand It isn't malware, it's ati's hotkey poller to change display settings according to keystrokes. –  abckookooman Feb 23 '13 at 6:21
    
How precisely did you determine that it was using 743M of RAM? What tool did you use? And precisely what did it report? (I'm thinking you're confusing RAM with virtual address space.) –  David Schwartz Feb 24 '13 at 21:01

4 Answers 4

up vote 1 down vote accepted

Click the Start button, select Run and type in: msconfig

Click the Services tab and uncheck the Ati HotKey Poller service and click Apply and then OK

You will be prompted to reboot. This should resolve the issue.

Source: I had the same windows XP, same graphics card and the same problem. This silly little hotkey polling service should consume kilobytes of memory but on my system was consuming 1.2 gigabytes! It has severely damaged my opinion of the programming abilities of ATI and the quality of the software.

share|improve this answer
1  
90% of the time when someone thinks a program made by a reputable company is consuming lots of memory, it turns out it's just consuming lots of virtual memory and a very tiny amount of physical memory. For example, if you memory-map a 1GB file, that uses 1GB of virtual memory and almost no RAM. Virtual memory is nearly free and there's no reason to conserve it. –  David Schwartz Feb 24 '13 at 21:03

The instructions for how to disable ati2evxx.exe are found here.

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Bob Feb 23 '13 at 10:27

I found a good solution that follows the laws of "don't touch the files, they might blow up."

Go to administrative tools->Services->ATI hotkey poller. Then, disable it or reschedule it to prevent the memory problem. This can be done to anything on the service list which causes problems.

share|improve this answer

I had seen that in another computer. Uninstalling and installing the drivers didn't help as it was a Windows problem. If none of the other proposals work, I'm afraid the only solution is to backup your data and format your computer to cleanly install Windows again. If you are lucky enough you might find an appropriate restore point to restore your PC when it didn't had that problem, otherise format is unavoidable. It's better to admit it and save yourself hours of trying to rectify it while at the same time you could have installed most applications from start.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.