Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Any time I'm playing a game (and even sometimes just using desktop programs), whenever the game accesses the hard drive the graphics freeze. Sometimes the audio stutters, most other times it doesn't.

I cannot figure out what's wrong. The games will run fine for a few seconds, but whenever something loads (i.e. I look at something new), the game will freeze for a few moments and then resume at full-force.

This happens at any point with any game, and is not your regular lag. Some games do so whenever a new model is loaded (or, for instance, when a block is broken in minecraft).

How can I go about debugging this issue?

The laptop isn't that old, and has done this ever since it was purchased. I was using the updated drivers for a while, and then tried the beta drivers with no luck. No overclocking is being done.


  • Alienware M17xr3
  • Windows 7 64-bit
  • NVIDIA GeForce GTX 560M
  • Intel Core i7-2670QM 2.20 GHz
  • 8 GB Ram

The laptop is an Alienware, so the model number is, of course, nowhere to be seen on the bottom. Model number added to specs.

EDIT: As suggested in the comments, here are the temps during both idle and gaming sessions. It should be noted that whenever the freeze occurs, the GPU usage drops to 0.

CPU Min/Max [core 1,2,3,4] : GPU
(All are in degrees Celsius)

  • Idle: 56/61, 60/68, 58/69, 52/61 : 62
  • Game 1: 63/76, 66/83, 66/83, 62/81 : 66
  • Game 2: 56/79, 61/85, 58/84, 54/81 : 66-67

Something else I should add is that the CPU power drops from around 32 watts to less than 15 (often times down to 7) whenever the freeze occurs - however, the programmer in me thinks that it's a side effect of the program itself due to the freeze and not being able to query the CPU.

Another note is that background music plays without interruption during these freezes; the CPU is still doing something when it freezes. Some of the game's sound effects will loop, but not in a soundcard freeze way.

share|improve this question
What operating system (be as specific as possible)? How much RAM? Have you changed any OS settings, particularly relating to memory management or power management? – David Schwartz Feb 23 '13 at 8:32
Your laptop has dual graphics card. Have you tried setting it to run on NVIDIA graphics only? – gronostaj Feb 23 '13 at 11:18
Can you install and run two programs (I do not care which specific ones); on to monitor CPU temperature, one to monitor the graphics chips temperature. Write down the values when the laptop is idle and when you are gaming (displaying them on a second screen while playing a full screen game is usually the easiest way). But before you do that check the event log messages. Any errors in there? For instance 'Thermal event' messages. Or 'disk read errors', esp. if the disk is set to older IO modes. – Hennes Feb 23 '13 at 12:57
@DavidSchwartz - Specs added. Nothing changed recently, other than a reformat; this issue has been around since its purchase. Reformatting neither fixes nor causes the issue. – Qix Feb 23 '13 at 23:15
Two other things to check: 1. use resource monitor to look at the disk, ignore transfer and watch the disk queue, see if it jumps when you notice the processor enter a lower P state or even C0 (idle). The drop in power usage may be due to throttling from high temperatures. Unless you manually calibrated the TJmax in your thermal monitoring program for that CPU I would bet the readings you got are off by 10-20C. Most programs are calibrated for a Thermal junction max of 91C while all mobile I series chips I have seen have TJmax closer to 100-110. – Not Kyle stop stalking me Feb 26 '13 at 13:49

My own suspicion is that this has a connection to the fact that your CPU model supports an impressive automatic overclocking from 2.2 to 3.3 Ghz, but that Windows 7 also supports CPU core parking. There might be some kind of a conflict between them going on in that souped-up Alienware model of yours.

You might be able to use the tool TMonitor (if it supports your CPU) to watch the power fluctuations as a complement to Resource Monitor.

To test my above theory, you might try to temporarily disable core parking, at least partially for a couple of cores.

Here is a very exhaustive article on the subject :
Disable CPU Core Parking Real-Time - No Reboot.

This article links to the ParkControl free utility that enables/disables CPU core parking for any given power profile (and which I never tried). There is also a discussion about how to do the same using PowerCfg.

I suggest to be very cautious and create a System Restore point before changing these parameters and to mind your backups. Before starting, the first step should be to use Windows Update to ensure that all your drivers are up to date.

If the test shows this as the cause (or if it doesn't), you could contact the Support of Alienware for a solution.

share|improve this answer
Learned something new! Didn't know what core parking was. Unfortunately, this didn't help anything at all. Resource monitor also ruled out any sort of network blocking issue or anything of the like. The CPU did fall during the freezes, but core temp already showed that. – Qix Mar 3 '13 at 2:58
The way I see this, voltage drop means that the CPU (or GPU) started using more power and it took some time for the power supply to adjust. If the cause isn't the core parking, but for example the overclocking kicking-in, it might be that the power supply is too slow to react and the whole house of electrical cards falls down. There are really too many variables here to analyze. So I suggest again to get in touch with Alienware Support for probable causes and then to (1) use your warranty if you still have it, or (2) ask a technician to verify the PSU, motherboard and GPU. – harrymc Mar 3 '13 at 7:45
What's weird is that I did a complete driver downgrade (to literally the lowest version I could get) and the issue went away. The debugger in me decided to go up one version to see if that fixed things; it brought the issue back, and when I downgraded again back to the lowest version, the issue was still there. I should have left it alone. Bottom line is that the drivers did make a difference. – Qix Mar 3 '13 at 11:36
That's also a matter for Alienware Support. – harrymc Mar 3 '13 at 14:35
I would try to determine which driver is at fault by dropping the system back to the lowest driver levels I could find. Then I'd upgrade one driver at a time until I determined which one it was. – John in Ohio Mar 6 '13 at 22:59

Without further details about your laptop, I'd point my finger at:

  1. A weak CPU that isn't up to the task.
  2. Overheating (caused by dust accumulation or insufficient ventilation). Clean out your laptop vents with a can of compressed air. Use a laptop cooling pad while gaming to keep temperatures down.
  3. If your laptop has a dual/switchable GPU feature, there might be a driver incompatibility behind this.

Can you post your laptop specs (or model number)?

share|improve this answer
Added specs. It's definitely not the CPU, unless i7's are not up to the task ;) – Qix Feb 23 '13 at 23:10
Also added temps. – Qix Feb 23 '13 at 23:58
I've accounted for all three of these; nothing helps. – Qix Mar 6 '13 at 10:26

i have a MX17r2 and it did the same thing till i updated the BIOS, reinstalled the graphics driver and reinstalled the updated Chipset drivers, Alienware's are VERY picky and complain a lot at every turn. If that doesnt work start from a fresh OS install and get all the drivers.

P.S. Ignore the alienware driver disk that came with it. Out dated drivers and for some odd reason they never work.

share|improve this answer
This was a new OS installation. I did flash the bios, but it was already at the newest (I flashed anyway). None of the chipset drivers pertained to anything relevant (all were for the tilt sensor and SD card and stuff). I've reinstalled the graphics driver several times now. – Qix Mar 10 '13 at 16:05
have you done a disk check to check for bad sectors on the drive? – Eryper Mar 26 '13 at 13:40
i have also been doing some research on the 560 mobile version and it does not like certain drivers, its a very picky mobile card, you might have to consider upgrading the card (which is easy in Alienware) or you can revert to the old driver for the card and leave it that way until NVidea comes out with a more stable driver for this card. – Eryper Mar 26 '13 at 14:01
yes I have tried disk checking; nothing came up. I may end up replacing the card or testing with a field replacement to see if it is, indeed, the card. – Qix Mar 27 '13 at 12:23

Here are my tips:
- try to disconect every (USB) device connected to your notebook and run your game
- is your HDD in perfect condition? Download "crystal disk info" and check IDs 03, 05, C5, C6-all must have RAW value 0
- download "furmark" and run benchmark
- download "prime95" - run blend test (you can combine it with furmark burn-in test for maximal load) !!!Watch carefully for temperatures!!!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.