Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I start vim from inside conEmu, then backspace is not working properly. I know its not a conEmu issue. It's a vim problem with console. I tried all things like

stty erase ^H, stty erase '^?', set bs=2 etc.,

I have also tried the advice at Backspace key not working in vim

but none of this worked!

Any advice for solving this.

share|improve this question
    
Which OS? Does it work if you use something else than conEmu? What does control-h do if you try it? –  Hennes Feb 23 '13 at 15:48
    
Microsoft Windows7. If I press Ctrl+H then it delete a character. And I am getting the same issue from inside cmd.exe. But I use conEmu that why I have specifically mentioned it. –  dearvivekkumar Feb 23 '13 at 16:12
    
I suppose, this may be a bug in ConEmu ANSI sequences processor. –  Maximus Feb 23 '13 at 22:17
    
comEmu is perfect It is not having this bug. As this problem happens in cmd.exe also. –  dearvivekkumar Feb 24 '13 at 9:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.