Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have mac osx server (10.7). I started web sharing. Tried to hit home page. Said no permission to go to /. So I found the httpd.conf file in /etc/apache2, edited it (that took a while) to make DocumentRoot /Library/WebServer/Documents

Still no permission. What am I missing?

share|improve this question
add comment

1 Answer

It's strange that your httpd.conf file was not already set to /Library/WebServer/Documents as that's the Apache default ...

Anyway, have you restarted Web Sharing since you made the change? Apache will not pick up changes to /etc/apache2/httpd.conf until you restart the service (or HUP the process).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.