Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a "Recovery" partition which I mistakenly thought was redundant after reinstalling everything to C:. "Recovery" was previously the "Active" partition. I set C: as the "Active" directory in disk manager (I am using Windows 7). When attempting to boot, the laptop now returns "BOOTMGR is missing".

I can go to BIOS and mess around with some stuff, but haven't found a way to change the active partition. I can disable various SATA drives (four are listed) and doing that sequentially changes the error message on booting, but no combination lets it boot.

I am travelling and don't have a USB key or bootable CD with me. I do have an external HD, but this other computer that I'm on right now (which is unusably slow) doesn't recognise it.

I think that the easiest solution will be to get hold of a USB key, make it bootable, and sort out the active partition from DOS. Any glaring shortcuts, alternative solutions or likely obstacles I'm missing?

Edit: I now have a USB key, can boot to DOS and run fdisk, which I expected to enable the active partition to be set. Unfortunately fdisk will not set NTFS partitions as active, and I haven't found any alternatives that run from DOS and will set NTFS partitions as active. At this stage it looks as though I will need to get Windows CDs as Olivier mentioned below.

share|improve this question
That's probably the best method or installing the boot loader to the drive instead of any partition (which I believe is almost always done by default on windows). But again, that requires either a USB or CD. Either of which are nearly universally available nowadays (gas stations even have low end flash drives oftentimes). In the bios, have you checked that the correct drive is the default boot option? A bit more risky is popping out the C drive putting it in another box (maybe using the external enclosure) and fixing there. – nerdwaller Feb 23 '13 at 20:42
Yes, the correct drive is the default boot option. For that matter I have tried changing the order and nothing unexpected / promising seems to happen. Thanks nerdwalker – Levi Feb 23 '13 at 21:47
Does your laptop have a network boot option? You might be able to get what you need from the other computer. – Radoo Feb 24 '13 at 0:04
I am not sure whether my laptop has a network boot option. There is nothing obvious listed in the bios. I've been searching for half an hour and not found clarity (partly because it takes a minute or two for each page to open on this other computer). Heading out to get a USB key now. Thanks Radoo – Levi Feb 24 '13 at 9:56

5 Answers 5

The active partition is the partition which the system will use to boot from. In your case, you've changed it so that the required bootmgr could not be loaded. You need to set the partition named 'Reserved by system' to active. This partition usually has no letter assigned to it. You can set this with a bootable live USB running a partitioning program. Below I've placed a link which describes how to make such a live USB running easeUS:

After you do this, everything should work again.

share|improve this answer
Thanks Jochem. I had tried several partition programs, and couldn't find one that both worked from DOS and allowed me to change the active partition on the hard drive. The problem is now solved for me (I am about to type up the solution I used), so I won't try the tool that you suggested. Hopefully it will save someone else some time. – Levi Feb 25 '13 at 12:25
@levi Good to hear it's solved – Jochem Kuijpers Feb 26 '13 at 0:29
up vote 3 down vote accepted

In the end I solved this by creating a bootable USB with the Windows ISO on it, and ran the "Repair" tool twice.

I essentially followed the instructions at:

  • In my case, I was using Windows 7 Professional (x86), so I downloaded that ISO.
  • Then I used the "Microsoft USB/DVD download tool" to create the bootable USB.

Many thanks for the help.

share|improve this answer

In case that you only have windows, you have to boot from a cd. There is no other option, I have searched a lot for other options but they don't exist.

The only other option to solve problems on Windows is to press F8 by booting and opening a recovery console, but it won't work in your case.

share|improve this answer
Thanks Olivier, I do only have windows, have searched a lot as well and appear to be heading in the same direction. I will provide an update if I can get an alternative to work. – Levi Feb 24 '13 at 20:04
Hi Olivier, in the end I booted from a USB with the Windows ISO on it, which I think is essentially the same. – Levi Feb 25 '13 at 12:26

Solution: The best and easiest option is to remove your hard drive and connect it to an external HDD enclosure. Connect the external HDD to another computer.

  • Right Click My computer Click manage
  • Select Disk manager
  • Right Click the recovery drive
  • Select "Mark Partition as active"

    Eject the external HDD from the computer. Remove the HDD and fix it on the computer that was missing the boot manager. The computer should start without any issues.

share|improve this answer

A factory reset will also fix this problem but be sure to back up your files when prompted to.

share|improve this answer
Thanks Travis. I guess this is obvious to you, but I wonder how someone might initiate a factory reset while the laptop won't boot and you don't have access to a bootable USB or CD? – Levi Dec 12 '13 at 21:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.