Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using Putty to connect to a Gentoo UTF-8 machine, backticks are represented as an "a circumflex": â

Putty makes a quote into an "a circumflex".

How to I prevent this from happening?

share|improve this question
add comment

1 Answer

putty shows quotes as a with a hat

Putty sometimes has problems converting char sets, you have to fiddle around with your character set translation on received data.

In Putty config, go here:

enter image description here

  1. In putty, go to the configuration, click the "Window" item.
  2. Click the "Translation" item.
  3. There will be a dropdown box that says: Received data assumed to be in which character set Set this to UTF-8. Or if it's already UTF-8, try one of the ISO-8859 varients.
  4. Save the settings and open a new terminal.
  5. The a circumflex is properly rendered as a back tick now.

For the curious, why does this happen?

http://www.downtowndougbrown.com/2012/02/fix-for-putty-displaying-a-instead-of-quotes-when-connected-to-a-linux-machine/

share|improve this answer
1  
If it's already UTF-8, then it is usually best to make the other end (i.e. the Gentoo box) UTF-8 as well. As someone speaking a language with accented letters, all my experiences with ISO-8859 have been horrible. –  grawity Feb 24 '13 at 2:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.