Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I often have trouble with menu options staying on-screen after I click them. How to solve?

share|improve this question
Duplicate of… ? – MattH Apr 29 at 10:34
up vote 37 down vote accepted

I've been having the same issue recently and it took me awhile to find this solution so hopeufuly it will help someone else too.

Restarting the Desktop Window Manager Session Manager (UxSms) seems to work perfectly.

Fire up a cmd prompt and run the following:

net stop uxsms
net start uxsms
share|improve this answer
This worked perfect – Brian Mar 27 '14 at 12:09
This did not work for me. – user1167442 Jan 11 '15 at 20:48
while this gets rid of the existing ones, it makes all future menus have a problem, unless I also use the solution from 3rdLion – BeowulfNode42 Sep 16 '15 at 5:37
  1. Control Panel > All Control Panel items > Performance Information Tools
  2. choose Adjust visual effects from the side menu.
  3. Uncheck "Fade out menu items after clicking".

The above process fixed it for me.

Obviously this is just treating the symptom and the real problem probably lies within the graphics drivers.

share|improve this answer
Trying it now. We'll see how it works. – Zonedabone Aug 3 '13 at 3:54
Haven't had any problems so far. Thanks for the fix! – Zonedabone Aug 11 '13 at 3:21

To remove the ghost menu-items, change the screen resolution and then change it back. This will cause the screen to completely redraw and remove the ghost menu item.

Easy way to change screen resolution:

  1. Right-click desktop and click screen resolution.
  2. Select a new resolution and click apply.
  3. Immediately click revert to get your old resolution back.
share|improve this answer
Do you have the latest video drivers installed? This is a workaround, not a solution for the actual issue. – Karan Feb 24 '13 at 5:39
I use a restricted access account so couldn't use Rob's approach, but this worked fine thanks. – MattH Apr 29 at 10:33

What I do in such cases is press CTRL-ALT-DEL, wait for the lock screen request, then return back to the original screen without locking.

share|improve this answer
I tried this first, but did not work for me – MattH Apr 29 at 10:31

Try pressing "F5" on the keyboard first- it might be all you need to do.


Also try this: move cursor over item, hold the left mouse button down over any part of the menu (don't release) - move cursor away and off the ghost menu, THEN release the mouse. Failing that- kill Explorer in Task Manager and restart it again from the Run box (again in Task Manager).

share|improve this answer
Just tried it. It didn't work even when I had just clicked the ghost item. Perhaps I'm not doing something right? – Zonedabone Feb 24 '13 at 5:31
Ok nowwww I know exactly what you're talking about. I was wondering why I'd never experienced these on my Windows 7 system which I use constantly. But it turns out I see them all the time but didn't know they had a special name! Here's all you do to swat them away: - move cursor over item, hold the mouse button down over any part of the menu (don't release) - move cursor away and off the ghost menu, THEN release Now the spooky ghost item has gone and you won't be having nightmares anymore. Failing that- kill Explorer in Task Manager. – Austin ''Danger'' Powers Feb 24 '13 at 5:46
I haven't had the issue recently, but this seems like the best solution. Could you make an official answer out of it so I can accept it? – Zonedabone Mar 16 '13 at 2:35
Sure! I'll append it to my original answer. – Austin ''Danger'' Powers Mar 16 '13 at 2:40

Just press CtrlShiftEsc and kill dwm.exe. It will disapear.

share|improve this answer
I'm more focused on prevention here. I know how to fix it. – Zonedabone Sep 5 '13 at 4:09

What I did was made a text document and typed this (from an earlier comment):

net stop uxsms

net start uxsms

Then, I saved it as "gg.cmd" and found the file. I then created a shortcut called "Ghost" to remember it. Then I right clicked the shortcut and then clicked properties. Then I clicked advanced and checked "Run as Administrator" and hit "apply" and "done". That's it! Just click the shortcut and it fixes it! You can put the .cmd file in another folder but don't delete it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .