Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 and the system clock is almost stuck within two hours. When I change it to the right time, the clock will stick to the right time + 2 hours (after reaching the right time + 2 hours it will go back 2 hours). The time zone is right, so it's definitely a virus or malware; but I scanned the system using avira and kaspersky with negative results.

Is there anyway to fix it without formatting?

share|improve this question
1  
Malware that changes the time for giggles? Hmm, not heard of that in recent years. Even if the time zone is right, you may not have (or have wrongly) informed Windows how the hardware clock of your machine relates to the time zone you set. What's the value of RealTimeIsUniversal under HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation? –  0xC0000022L Feb 24 '13 at 15:10
    
SE Asia Standard Time –  Farok Ojil Feb 24 '13 at 15:29
    
Your comment completely disregards the request for that piece of information. Also see: blogs.msdn.com/b/oldnewthing/archive/2004/09/02/224672.aspx –  0xC0000022L Feb 24 '13 at 15:52
    
this is the value of the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation i didn't find the RealTimeIsUniversal key in the registry. –  Farok Ojil Feb 24 '13 at 16:29

4 Answers 4

up vote 1 down vote accepted

You could have a bad/rouge time server defined, which dynamically updates your system time. Please open a command prompt in administrator mode, and input this command:

w32tm /query /status

Please paste the "source" line.

It may also be possible that the time defined in your BIOS is not being set properly. When your PC powers on press DEL or F2 to enter the setup utility, and in general CMOS settings, ensure the time is set correctly there.

share|improve this answer
    
source: display the time source. –  Farok Ojil Feb 24 '13 at 15:20
    
That's a very odd response. This line should be a server address of which is being used to receive time updates from. What does the source IP value say in above line? (line starts with ReferenceId) –  Adambean Feb 24 '13 at 15:22
    
sorry i run the wrong one first, but when i'm running the right one this is the result The following error occurred: The service has not been started. (0x80070426) –  Farok Ojil Feb 24 '13 at 15:31
    
after starting the service and run the command again this is the result Source: Local CMOS Clock –  Farok Ojil Feb 24 '13 at 16:39
    
Ah in that case you will need to enter your BIOS setup utility when your PC powers on and set the correct clock there. It's in that "Press DEL to enter setup" part when your PC powers on. Might be F2 though. –  Adambean Feb 25 '13 at 5:39

Have you changed something in the Windows Services ? Have you disabled the Service Software Licensing?

You must do this through safe mode.

  1. Remove all floppy disks, CDs, and DVDs from your computer, and then restart your computer.
  2. Click the Start button, click the arrow next to the Lock button, and then click Restart.
  3. Do one of the following:

    • If your computer has a single operating system installed, press and hold the F8 key as your computer restarts. You need to press F8 before the Windows logo appears. If the Windows logo appears, you will need to try again by waiting until the Windows logon prompt appears, and then shutting down and restarting your computer.

    • If your computer has more than one operating system, use the arrow keys to highlight the operating system you want to start in safe mode, and then press F8.

    • On the Advanced Boot Options screen, use the arrow keys to highlight Safe Mode with command prompt, press Enter

    • Log on to your computer with a user account that has administrator rights.

    • Type services.msc in Windows Run Command (Win+R)

    • Then in the list of services locate Software Licensing. Right-click it, select Properties

    • Change “Startup type:” to Automatic, then click OK. Restart you computer

Report back to us, did it solve the problem ?

share|improve this answer
    
do you mean 'software protection' it was on automatic(Delay start) i change it but i can't tell now i have to wait two hours because i change the clock already in the bios. –  Farok Ojil Feb 24 '13 at 16:23
    
I am not sure if it is called software protection. You must do this through safe mode. –  Devid Feb 24 '13 at 16:26
    
If possible, could you please explain how this is supposed to help with the issue at hand? –  Bob Feb 24 '13 at 16:28
    
@Bob the user reported that he gets the following error: The following error occurred: The service has not been started (0x80070426) This is known to occur when the service Software Licensing is disabled (might now be called Software Protection). The above steps describe how to enable the service again. –  Devid Feb 24 '13 at 18:38

It almost sounds like its in your BIOS. I once had an issue like this and basically reflashed my BIOS. That fixed my issue. Mine wasn't quite like yours however it smells like its in your BIOS. Have you tried installing other versions of Windows and seeing what happens to the clock? Just something to think about. By the way if you do end up reflashing your BIOS, there's a point where you do not want to turn off your computer. I'm sure the upgrade software will make you aware of that though.

share|improve this answer

I have seen exactly this issue before. It was a very old installation of Windows, with (presumably) some sort of corrupted system file. Using the right time zone would cause the wrong time to be displayed. What worked for me was simply reinstalling Windows (which, incidentally fixed all the other system problems with that old installation of Windows in the process). I rarely advise jumping straight in and doing a reinstall, but having seen this myself, I think you should be open to the idea. If you do a reinstall (or repair install) you could have it fixed today- otherwise it will just drag on for a while. By the way I don't like it when people say "...blah blah blah, so it's DEFINITELY a virus or malware!". The one thing I can guarantee is that it's NOT malware. Malware is too often the scapegoat for things people can't explain IMO.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.