Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Win7 installed on an HDD (C drive) that has all my stuff on it. Recently I bought an SSD (E drive) and today I have been migrating things over. I changed the registries so that C is my default installation drive using this guide. My problem is that some of my desktop shortcut's targets point to C:.... for applications that are installed in E:.... The start in field is still correct, but the target is wrong. When I try to change the target, I am able to edit it to E:.... and click apply, but when I close the properties window it goes back to C:.... Why is this and how can I fix it?

Edit: The applications themselves are fine, its just the shortcuts that are messed up. If I navigate to their folder everything works.

share|improve this question
Sorry, your link is broken. Which values in your reg did you modify? – icu222much Feb 24 '13 at 16:19
I just formatted my computer to install my OS on my SSD, and apps in my HDD. I've also modified my reg keys (CommonFilesDir and ProgramFilesDir) to point to my HDD but I noticed the 32-bit software doesn't install there and sometimes Win7 has trouble finding them. – icu222much Feb 24 '13 at 16:21
The link is fixed. – David Grinberg Feb 24 '13 at 16:22
I'm trying to add a command line parameter to a Windows 7 shortcut, that starts with an at symbol (@). Although it seems to save properly when hitting [Apply], it actually doesn't. Changing it to (/@) works...but is not what the application I'm using requires: :( – aliteralmind Oct 29 '14 at 15:12

If I understand you right, your programs are working except the shortcuts on your desktop are all messed up. If this are simply shortcuts on your desktop, just delete them and recreate them. To recreate them just go to them in your program menu, use your RIGHT mouse button to drag them to your desktop. When you release it, select "create shortcut".

share|improve this answer
Yeah... I know I could do that is (a) not interesting and (b) doesnt fix the underlying problem. While C is my default drive, I still install a bunch of stuff to E. I dont want to have to recreate a shortcut EVERY time I install something to E. – David Grinberg Feb 24 '13 at 18:58
Are you having to change the icon now when you install something new? It doesn't point to E now if you install it on E? – Dale Feb 24 '13 at 19:02
Yes, the icon also points incorrectly to C and I need to reset it to its actual location in E. And yes, this only happens when I install to E. Things installed to C work fine. – David Grinberg Feb 24 '13 at 19:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .