Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After my operating system Windows 8 crashed, I tried to format my hard-disk but Windows 8 shows error:

We couldn't create a new partition or locate an existing one. For more information, see the setup files.

I tried to solve it as follows:

  • Repair computer
  • go to advanced tools
  • start command line
  • start DISKPART
  • type LIST DISK and identify my disk number as disk 0
  • type SELECT DISK 0
  • type CLEAN
  • EXIT (twice)

I've combined my disk to a single one, there are no other disk partitions when I tried the above.

Any Idea? Is my hard-disk is damaged or is this a software problem? I have recovered all data from the hard disk to another external hard disk with a Fedora 15 Live CD.

share|improve this question
It sounds like you can't convince Windows to purge current partitions. i had trouble convincing Windows to delete the special System Reserved partition. i can't remember how i solved it; enough selecting, and deleting, and purging, and removing. But i suggest the brute force approach. Download Western Digital's hard-drive tools, and tell it to Write all zeros to the drive. That will get rid of every partition. That way Windows can't refuse. – Ian Boyd Feb 24 '13 at 16:47
While you have the WD tools you might as well use it to check the hard drive and make sure a failing HD is't the root of the cause, also, you might want to run memtest86+ (1 pass), bad RAM can cause all sorts of strange issues as well.. – TheXed Oct 8 '13 at 21:10
Can you use GParted live cd and post a screenshot here? – tumchaaditya Jan 8 '14 at 22:53
I also had the same issue @Bishnu . I couldn't get any help from internet. Every internet thread says to check for any other extra hdd or any kind of sd card is plugged or not. Very lately I found that the installation media (8gb Transcend) has a SecureDrive(CDFS file system) this was the main reason I couldn't able to install the os. So I just did the installation through another pendrive which doesn't have any extra partition. Eveything went successfully. Uffffffff.. It took me a whole day to find out this. I hope this might help you – Akbar Sha Ebrahim Jul 28 '14 at 8:46
@Bishnu Bhattarai, similar situation was resolved after updating/flashing the BIOS – pun Sep 23 '15 at 10:42

If you are installing from a USB device and you are getting this error, then try this. Go to repair/cmd and copy all the files from USB to the drive where you wish to install to. If D: is USB, E: is your Windows partition, then type in these commands.

xcopy /E /H *.* E:\

Then set your Windows partition as active with diskpart:

list disk
select disk X

Where X is your HDD or SSD where you want to install Windows.

list partition
select partition X

Now unplug the USB, close cmd window and reboot the PC. Now the installer will start from your HDD and you can install to the same location. You can delete the installation files when you're done (compare with USB contents).

share|improve this answer
I had the same error as a question author and this solution worked great as an alternative to diskpart clean. diskpart clean deletes all partitions - it's not good if you don't want to lose your data. I did it once by mistake and I had to recover my partition with testdisk tool. Thanks for this solution! – akn Feb 18 '15 at 21:35
This guy is brilliant, this solution worked for me and saved me . Thanks a lot – Ahmed Kamal Apr 24 '15 at 19:02

Try to following methods:

1)Check if you have an SD Card in the system. If you do, you remove it and run setup again.

2) Once the setup fails to find the partition, just close the setup window (the top-right-hand side red X does the job).

From that point, you should be brought back at the initial setup screen.Choose "Repair" then go to the advanced tools and start the command line.


Type LIST DISK and identify your SSD disk number (from 0 to n disks).

Type SELECT DISK where is your SSD disk number.






Type EXIT twice (one to get out of DiskPart, the other to exit the command line tool)


share|improve this answer
I have already tried this but it didn't worked for me. First read question carefully before you answer. – Bishnu Bhattarai Feb 24 '13 at 16:49
I have no any OS in my laptop.I am using my friends laptop. I want to install windows 8 but I cannot go further while installing I am blocked in the error that i mentioned in my question. I can't install windows 8. Installation of windows 8 is not working. – Bishnu Bhattarai Feb 24 '13 at 16:58
how do you install Win8? Fro ma DVD or USB drive? I had the same issue when I tried to install Win8 RP with an USB 3.0 drive (32GB). The only solution for me was to use a DVD-RW. – magicandre1981 Feb 24 '13 at 17:01

another reason for this error could be because of attaching multiple usbs/SD card. Detach all USBs, SD card and External HDD other than the Windows live USB. It should work.

share|improve this answer

After you rewrite the partition table, reboot the computer. This has solved the issue for me several times. It looks to me like Windows isn't able to detect when the table changes until then.

share|improve this answer

Try using a USB 2.0 flash disk instead of a USB 3.0 disk regardless whether the target system has USB 3.0 ports or not. (Assuming of course that the installation is being done with a USB flash disk)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .